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What's New in summit.factory V1.0.01 (01/01/2026)
Application rebuild to stay current with the latest version of Java 21, required libraries and build tools.• 

Previous Versions
V1.0.00 (23/12/2023)

The first official release of summit.factory.• 

V0.4.00 (20/11/2023)

Fixed an issue in the database that was erroneously flagging duplicate patches in different files as
being different.

• 

Provided a workaround for the OSX Java file selector bug that reports a non existent directory when
you have double clicked a directory to select it.

• 

Improved registration process. You now no longer have to quit the program to activate the disabled
features once registered and activated.

• 

Application rebuild to stay current with latest version of Java 17, required libraries and build tools.• 

V0.3.00 (01/09/2023)

External Beta release with the application now fully packaged and ready for full testing• 

V0.2.00 (24/07/2023)

Internal Beta release that added library features• 

V0.1.00 (03/01/2023)

Internal Beta release for internal testing• 
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Installation and Configuration of summit.factory
summit.factory is downloaded as a self installing file, so installation is automatic, and for most users little else,
if anything, needs to be done to get up and running.

A native installer for Windows is also available.

Simply download the installer from the x.factory Products Page/a> for your platform (PC, OS X or Linux) and
run the installer, following the installer prompts.
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Registering summit.factory
You need to register summit.factory to allow data to be saved to your computer and for Library Support to be
enabled.

Please refer to the x.factory Librarian Registration Page for details on how to register summit.factory.
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Running summit.factory
Starting up summit.factory is as simple as starting any application, simple double click on the icon and you're
away.

If you have registered summit.factory, then the Library will be created (if it doesn't already exist) and opened.

During start-up, a "Splash Screen" is shown. This stays visible until a few seconds after the program has
loaded and is ready for use, but can be dismissed at any time by clicking on the Splash Screen.

summit.factory remembers the size and position of the main window between sessions, so the main window
will be sized and positioned as you left it the last time.

PC
Simply double click on the program icon for the program either in an Explorer shell, or from the desktop if you
let the installer placed a shortcut there.

You can also select the program from the Start Menu. By default, summit.factory can be found under the
x.factory Librarians Program Group.

MAC OS X
Navigate to the Applications folder in Finder and double click the summit.factory application.

You can also create "Aliases" of the application and place them anywhere you wish, such as on the desktop

To make an alias you can choose any one of the following methods:

Click the summit.factory item you have just identified and hold down the mouse button. Then, while
holding down the Command and Option keys simultaneously, drag the item to where you want the
alias to appear then let go of the mouse button and finally release the two keys. This will create an
alias at your desired location. While dragging, the ‘ghosted’ item will display a shortcut arrow which will
remain on the aliased icon when it has been created.

• 

Hold down the Ctrl key, and then click the summit.factory item as identified previously. The context
menu will be displayed, and one of the choices will be Make Alias. Click that option, and then release
the key. The summit.factory alias will appear next to the original item and can be dragged to your
location of choice.

• 

Select the summit.factory item you identified previously by clicking it once then press Command-l
(lowercase L). The summit.factory alias will appear next to the original item and can be dragged to
your location of choice.

• 

Click the summit.factory item once to select it, and then from the File menu, select Make Alias. The
summit.factory alias will appear next to the original item and can be dragged to your location of
choice.

• 

Note that if your alias does not have a small arrow in the lower left corner then you have not correctly created
an alias and have probably just dragged the application launcher to a new location. If so, drag it back to the
Application folder and start again.

Command Line
You can also startup summit.factory from a command shell (e.g. MsDOS). Simply change directory to where
summit.factory is located and type the following:

java -jar summitfactory.jar
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The summit.factory Window
The main summit.factory window on OS X looks like this

The main summit.factory window on Windows looks like this

The summit.factory user interface is a Multiple Document Interface (MDI), which allows you to have more than
one file open at a time.

The interface is divided into the now familiar layout of (from top to bottom):

The Title Bar• 
The Menu Bar (on OS X this appears at the top of the screen)• 
The Tool Bar• 
The Desktop• 
The Status Bar• 
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Menu Bar
The summit.factory menu bar provides a means of selecting common operations; typically those that affect a
complete file, or those that don't fit naturally upon a context sensitive popup menu.

Keyboard Shortcuts are provided for common operations.

summit.factory also provides context sensitive popup menus, which are accessible by right clicking over data
shown in a Child Window. Naturally the contents of the popup menus varies according to the type of data over
which the menu was popped up.

Main Menu Headings

The following menu headings are available.

Apple Application Menu (OS X only)• 
File Menu• 
Edit Menu• 
View Menu• 
MIDI Menu• 
Tools Menu• 
Window Menu• 
Help Menu• 
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The Application Menu

The Application menu is available on OS X to provide a native look and feel for OS X users; some menu
options from the standard menus are migrated here (where OS X Users would expect them to be).

About summit.factory...

This menu provides the standard OS X application menu, with the following summit.factory specific options
along with the standard OS X options for Services (none defined for summit.factory) and Window control.

Displays the summit.factory About Dialog, which provides some basic information about the program, such as
the version number.

Preferences ...

Opens the summit.factory Preferences Dialog.

Quit summit.factory

Exits the summit.factory application.

If any files have been modified and have not been saved, you will be given the option of saving them.
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The File Menu

The File menu provides the following options (OS X and Windows versions are shown):

New ...

Shows the Create New File Dialog, which allows you to create a new file.

Open ...

Shows the Open File Dialog, which allows you to open a specified file.

Save

Saves a file using its current name.

This option is only enabled if your copy of px.factory is registered.

If the file in question is a newly created file, then the Save File Dialog is brought up to allow a name to be
entered.

Save As ...

Saves the selected file after a name has been entered in the Save File Dialog.

This option is only enabled if your copy of px.factory is registered.

Save All

Saves all files that have been modified using their current names.

This option is only enabled if your copy of px.factory is registered.

Open Workspace ...

This option allows you to select a previously saved Workspace, which is a Collection of open windows, and
their size and position within the main px.factory window.

When you select this option, a dialog opens which allows you to select an px.factory workspace file (EXW).

Save Workspace ...

This option allows you to save the current size and position of the main px.factory window, and the
arrangement of the open windows within px.factory to a Workspace file.

This option is only enabled if your copy of px.factory is registered.
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Export to

This option brings up the following sub menu:

These options allow you to Export the data in the currently selected file to a variety of different formats.

Exit

This menu option is not available if the host operating system is OS X. On OSX there is a Quit menu option in
the px.factory Application Menu.

Exits the px.factory application.

If any files have been modified and have not been saved, you will be given the option of saving them.

Recently Opened Files

The file menu also contains a list of recently opened files to allow easy access to files that you are currently
working upon. The recently open files list appears at the bottom of the file menu.
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The Edit Menu

The Edit menu provides the following options:

Undo

Undoes the previous edit stored in the Undo Buffer.

Redo

Redoes the next edit stored in the Undo Buffer.

Clear Undo Buffer

Clears the Undo Buffer.

Cut

Places a copy of the selected Object(s) onto the Clipboard and deletes the selected Object(s) from the file.

Copy

Places a copy of the selected Object(s) onto the Clipboard.

Paste

Copies the Object(s) on the Clipboard into the highlighted location within the current file. If you cannot perform
a paste at this location (e.g. trying to copy a Set List onto a Program) then this menu item is disabled.

Find ...

summit.factory supports the ability to find Objects by name.

Searches start from the currently selected Object.

Selecting the Find ... option brings up the Find dialog, that allows you to specify the string to search for, along
with options that can be used to refine the search.

Find Next

If you have defined the Find criteria within the Find dialog, then this option will repeat the search using the
same criteria.

Find Category ...

You can also search by category be selecting Find Category ... option, which brings up the Find Category
Dialog.

Find Next Category

If you have defined the Find Category criteria within the Find Category dialog, then this option will repeat the
search using the same criteria.

Goto ...

Selecting this option brings up the Goto Dialog, which allows you to quickly navigate to a numbered Object.
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The View Menu

The View menu provides the following options:

Note how some of the options change depending on whether or not the Child Window is split.

The View menu provides the following options upon PC:

Note how some of the options change depending on whether or not the Child Window is split.

When the Child Window is split the Left/Top Pane and Right/Bottom Pane menu options have the following
sub menu.

Tool Bar

When checked the summit.factory Tool Bar is visible.

Status Bar

When checked the summit.factory Status Bar is visible.

No Split

When checked the current Child Window is not split.

Horizontal Split

When checked the current Child Window is split horizontally.

Vertical Split

When checked the current Child Window is split vertically.

Tree

When checked the main/left/top pane in a Child Window displays data in a Tree View.
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Table

When checked the main/right/bottom pane in a Child Window displays data in a Table View.

Refresh

Refreshes all open Child Windows.

This command is provided in case the screen is not properly updated following an edit operation. There are a
couple of odd bugs I cannot track down on screen updates. So if you come across them as well, then this
command will force a redraw of the windows.

Preferences ...

This menu option is not available if the host operating system is OS X. On OSX there is a Preferences...
menu option in the  summit.factory Application Menu.

Opens the summit.factory Preferences Dialog.
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The MIDI Menu

Note: The MIDI option is only visible if you have registered px.factory and enabled MIDI support in the MIDI
Preferences Tab in the Preferences Dialog.

The MIDI menu provides the following options:

Import Peak/Summit Synthesizer From MIDI

Imports Patches and Multis (Summit only) from the Peak/Summit via MIDI to the currently selected Window.

Export Peak/Summit Synthesizer Data to MIDI

Exports Patches and Multis (Summit only) to the Peak/Summit via MIDI from the currently selected Window.

MIDI Router ...

Opens the MIDI Router Dialog which allows you to use another keyboard to audition Peak/Summit Data.

MIDI Preferences ...

Opens the Preferences Dialog with the MIDI Preferences Tab active.
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The Tools Menu

The Tools menu provides the following options:

This option is only enabled if your copy of summit.factory is registered.

Library Information ...

Opens the Library Statistics dialog.

This option is only enabled if your copy of fs.factory is registered.

Batch Import to Library ...

Opens the Batch Import To Library dialog.

This option is only enabled if your copy of summit.factory is registered.
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The Window Menu

The Window menu provides the following options:

In the example given above, you'll see that after the predefined menu options there are menu options that
allow you to select the windows currently open within px.factory.

Tile Horizontal

Arranges all non-minimised Child Windows along the horizontal axis.

Tile Vertical

Arranges all non-minimised Child Windows along the vertical axis.

Maximise Windows

Maximises all Child Windows so that they all occupy the size defined by the desktop.

Restore Windows

Restores all maximised/minimised Child Windows to their normal state.

Minimise Windows

Reduces all Child Windows to their iconised state.

View Peak/Summit Synthesizer Data

Opens or closes the Peak/Summit Synthesizer Window which provides a view on preset and user DX synth
data.

View Peak/Summit Library

Note: This menu option is only visible if you have registered summit.factory.

Opens or closes the Peak/Summit Library Window which provides a view on the Peak/Summit Library.

 The summit.factory Window 15



The Help Menu

The Help menu provides the following options (OS X and Windows versions are shown):

Search

OS X only. This is a standard OS X Menu function currently not working with summit.factory. One day....

Get Help on summit.factory ...

Displays the summit.factory Online Help system.

View Tips and Tricks for summit.factory ...

Displays the summit.factory Tips and Tricks Dialog.

View PDF Documentation for summit.factory ...

Displays the PDF documentation for summit.factory. Note that there needs to be a registered viewer for PDF
files on your system for this command to work

View License Agreement for summit.factory ...

Displays the summit.factory License Agreement in a dialog box.

View License Agreement for summit.factory ...

Provides a link to the x.Librarian's Support Page.

About summit.factory ...

This menu option is not available if the host operating system is OS X. On OSX there is an About
summit.factory menu option in the  summit.factory Application Menu.

Displays the summit.factory About Dialog, which provides some basic information about the program, such as
the version number.

Register and Activate summit.factory ...

Displays the summit.factory registration and activation Dialog.

See the Registration Section for details of how to register summit.factory.
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Tool Bar
The Tool Bar contains buttons for common operations, such as opening and saving files.

   Displays the New File Dialog to allow you to select the type of file to create
   Displays the Open File Dialog to allow you to select a file to open
Saves the currently selected file

   Displays the Save As Dialog to allow you to select a different name for the currently selected file
Saves all the open files to disk

   Cuts the selected Objects and places them on the Clipboard
   Copies the selected Objects and places them on the Clipboard
   Pastes the contents of the Clipboard to the current selection. If you cannot perform a paste at this location

(e.g. trying to copy a Set List onto a Patch) then this menu item is disabled
Undos the previous edit
Redos the previous edit

   Displays the Find Dialog to allow you to define the search criteria and then search for the first occurence
   Searches for the next occurence of the search criteria defined in the Find Dialog
   Imports Patches/Multis/System Settings from the Peak/Summit via the MIDI interface
   Exports Patches/Multis/System Settings to the Peak/Summit via the MIDI interface
   Displays the Preferences dialog where you can configure summit.factory
   Displays the summit.factory Online Help index page
   Enables Context Sensitive Help
   Displays the Tips and Tricks Dialog
   Displays the About Dialog

The Save buttons are only enabled if summit.factory is Registered.

The Tool Bar can be dragged and made a floating toolbar by clicking and dragging the handle to the left of the
Tool Bar.

The Tool Bar can also be dragged to a different window border other than the top border.

The Tool Bar can be hidden/unhidden by the Tool Bar menu option on the View menu.

The Tool Bar whilst floating can be docked once more by closing it.
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Desktop
The Desktop portion of the window is where the Summit data is portrayed. Several files may be opened and
shown within Child Windows upon the Desktop portion of the window. The following example shows
three Child Windows open on the Desktop, each showing different views.

The Window Menu provides menu options to:

Tile (either vertically or horizontally) all Child Windows that are not iconised• 
Minimise all Child Windows• 
Maximise all Child Windows• 
Restore all Child Windows• 
Select a specific Child Window• 

When a file is opened, a Child Window is added to the Desktop Area.
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Child Window
The Child Window provides the View upon the data within the file it is associated with.

The Child Window is maximised by default when it is opened, and can be minimised, restored or closed by the
buttons to the right of the Child Window's title bar.

The menu options on the View menu can be used to change the View between a Tree view and a Table view,
and a Child Window can be either split horizontally or vertically split to show any of the following
combinations:

A Tree and a Table• 
A Table and a Tree• 
Two Trees• 
Two Tables• 

The default Child Window View applied when a file is opened is set in the Default View Tab of the Preferences
Dialog.

The following example shows a Child Window that is split and showing both a Tree View and a Table View on
the same data.

The Tree and Table views support drag move and drag copy operations, and the views will automatically
scroll whilst drag operations are in progress.
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Tree View

The Tree View shows the file data as a hierarchical tree, and can show more information than the Table View.
The following example shows a split Child Window with two Tree Views, one showing Patch Bank A, and one
showing Multi Bank A with Multi 001 expanded to show the Layers within the Multi.

Basically, information is shown as a set of hierarchical Objects. Objects may have children attached to them,
and they themselves may have further child Objects (e.g. a Multi Object, has a child Objects for all of its
Layers).

The basic tree structure is a Root Object at the top of the tree under which are various Object Collections
which themselves contain further data. The top level Collections that can be found under the root node varies
upon the file contents

Objects are displayed in one of two colours:

Black if the Object has data in it.• 
Red if the Object is "empty" (.g. a Patch Collection).• 

The Tree View allows multiple Objects to be selected, which is useful for performing operations only upon
certain Objects. You can only perform operations upon Objects of the same type.

If you wish to perform an operation upon all Objects in a Collection, simply select the Collection containing the
Objects.

If you right click over an object or selection of objects within the Tree View, a context sensitive popup menu
will appear that provides the editing operations that can be performed upon the object(s).

Objects can be Copied and Moved either within or between Child Window Views using Drag and Drop.
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Table View

The Table View provides a more high level overview of the data than the Tree View, and the representation of
the data is more compact. The following example shows a Child Window with a single Table View providing
information on a file's Patches in one of the Patch Banks.

The Table View can only show one Collection of Objects at a time.

Each row within the table shows one Object.

Objects can be Copied and Moved either within or between Child Window Views using Drag and Drop.

If you right click over an object or selection of objects within the Table View, a context sensitive popup menu
will appear that provides the editing operations that can be performed upon the object(s). The cells in a Row
that contain the Object Category and Object Name (if available) can be directly edited by clicking in them.

The context menu also provides the options to select what data view. In the example below, the table is
currently showing Patch Bank A, but a selection is being made via the menu to change to the Patch Bank B
Bank.

You can also double click a high level collection (e.g. Patch Bank Collection, Patch Banks) and summit.factory
will move down to the next level until you get to discrete objects (e.g. Patch). You can double click with the
ALT key (OPTION key on OS X) held down to traverse upwards.
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Peak/Summit Synthesizer Window

The Peak/Summit Synthesizer Data Window is made visible by ensuring the View Peak/Summit Synthesizer
Data option in the Window Menu is checked.

This Child Window is a special View that shows the Peak/Summit data that has been imported and exported.

The purpose of this windows is to allow drag and drop transfers of Patches and Multis between summit.factory
and the Peak/Summit via the MIDI Interface.

And it allows you to import and manipulate Peak/Summit data without creating SYSEX files, if you wish to
make a quick edit. If you edit data in this window then if the Automatically Update Peak/Summit After
Synth Window Edit option is ticked in theÂ MIDI Preferences tab in the Preferences Dialog
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Summit Library Window

Note: This Window can only be opened if you have registered summit.factory.

The Summit Library Data Window is made visible by ensuring that the View Summit Library option in
the Window Menu is checked.

This Child Window is a special View that shows the contents of the Summit Library.

Like the standard Table View, you can select the view of type of objects that you wish to view (e.g. Patch or
Multis, Performances, etc.), which includes Files and Authors that are stored in the Database.

The window can be configured to be either a Tree or a Table view. The Table view is recommended because
filtering capabilities are available, which are described below.

Summit Library Table View Columns

The following columns can be found in the Library table. Not all columns are available in a table view,
depending on the type of data being viewed. For example, only Patch or Multis have the Type Column.

Category The Category of a Patch. This column is not shown when the Multi view is selected.
Name The Name of an Object. Note that this name can be up to 50 characters long, so you can

provide a more meaningful name for an object within the Library (the original name is preserved
for when the object is copied from the Library).

Type or
Mode

The type of the Patch; either Peak or Summit, or the Mode of a Summit Multi.

Rating Each Object object can be assigned a rating, from unrated to five stars. Filtering on this column
will allow you to quickly find you favourite items.

Comment Each object can have a comment associated with it of up to 100 characters. For example, you
could use this field to contain keywords that you use to describe a sound's character in more
detail. This could help you to define a filter to search for a sound.

Author You can define the Author for each Object. This field defaults to "Unknown" when objects are
added to the Library. You can setup summit.factory to prompt you for an Author name when a
new file is being added to the database.

Source The name of the source file that an Object was copied from when it was added to the Library.
Table Sorting

You can sort a table by a column by clicking on a column heading in the table header. for example to sort
patches by name, then click on the Name column heading. The sorting will cycle through the following states
each time you click a column header:

Unsorted• 
Sort Ascending• 
Sort Descending• 
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Data Export

You can export a Patch or Multi by right clicking over it and select the Export to Peak/Summit Edit Buffer
option. Alternatively you can double click or triple click the Patch or Multi in a field that is not editable and this
will also export the object. The triple click action will also open the MIDI Router.

If you check the Automatically Export Selected Item option, then when you select a Patch or Multi it is
automatically exported to the Patch or Multi Edit Buffer.

This, for example, allows you use the cursor keys to move though the library Patches or Multis and have them
automatically exported to the Edit Buffer without having to do anything else. Please note however, that with
this option enabled, then the scrolling is slowed down. Don't forget that you can double click on a Patch or
Multi to export it.

Table Filtering

The database table provides a very comprehensive filtering capability, which allows you to filter on any
column or combination of columns. For example, you can filter on patches with a name that contains the
phrase "Fred", combined with a category filter for "pads", combined with a type filter for AWM patches, and
finally filter for those which have a three star rating.

You can enter a filter for each column using the filter header that is above the table column names.

Table filtering works in conjunction with table sorting

A filter with a grey background is restricted to filtering by items that you can select from the drop down list. For
example, a rating value can only be unrated or rated between 1 and 5 stars

A filter with a yellow background allows you to enter a PERL Regular Expression string that acts as a filter.
Consider the following PERL examples for filtering by name:

drum will match all names containing the phrase drum (anywhere in the name);• 
^t will match all names beginning with the letter T ('^' anchors the search to the start of the name);• 
[0-9]$ will match all names ending with a number character between 0 and 9. ('$' anchors the search
to the end of the name);

• 

^M[0-9] will match all names starting with letter M followed by a numeric character.• 

That is just an overview of how you can use regular expressions for filtering. More details for how you can
form regular expression pattons can be found on the PERL Regular Expression Page

The drop down list for a Perl Regular Expression filter provides a history of the search terms entered during
the session.

Table Filter Controls

At the bottom of the table is a toolbar with the following controls:

Enable Filter Turns the filter on or off.
Configure Filter Brings up the Configure Filter dialog box allowing you to control the default behaviour of

how the Rating, Comment, Author and Source File columns are filtered.
Reset Filter Resets the filter.
Table Filter Configuration

When the Configure Filter Dialog button is selected, the following dialog appears that allows you to control
the behaviour of the filter for specific columns.

Rating - allows you to select whether or not an exact match is required, or if the filter is to allow
ratings greater than or equal to the one shown.

• 

Comment - allows you to select if a PERL Regular Expression can be entered, or if choices are
restricted to the choices provided in the drop down dialog.

• 

Author - allows you to select if a PERL Regular Expression can be entered, or if choices are restricted
to the choices provided in the drop down dialog.

• 

Source File - allows you to select if a PERL Regular Expression can be entered, or if choices are
restricted to the choices provided in the drop down dialog.

• 
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Status Bar

The Status Bar provides the following pieces of information (from left to right) for the Child Window which is
currently selected:

The name of the file currently open, if any. If no file has been selected then this field is blank• 
The type of the file• 
Whether or not the file has been modified• 
If the left/top split pane is a table this indicator identifies what the table is showing (Patches, Multis,
etc.)

• 

If the right/bottom split pane is a table this indicator identifies what the table is showing (Patches,
Multis, etc.)

• 
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summit.factory Program Features
summit.factory provides the following features:

File Operations• 
Undo/Redo Support• 
Clipboard Support• 
Find and Goto Support• 
Editing Features• 
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File Operations
summit.factory supports the following file operations:

Create New Files• 
Open Existing Files• 
Save Files• 
Open and Save Workspaces• 
Export Data• 
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Create New File

When the New File ... option from the File Menu or the  button on the Toolbar is selected, the following
dialog is shown:

This dialog allows you to select what banks are created in the file from the following:

Patch Bank A• 
Patch Bank B• 
Patch Bank C• 
Patch Bank D• 
Multi Bank A (Available when the Synth Type is set to Summit)• 
Multi Bank B (Available when the Synth Type is set to Summit)• 
Multi Bank C (Available when the Synth Type is set to Summit)• 
Multi Bank D (Available when the Synth Type is set to Summit)• 
Settings• 

The All or None buttons allow to set or clear all banks in one operation.

The initial values for these settings are setup in the New File Default Preferences Tab in the Preferences
Dialog.

The new data file is given a name in the form of "summitFactory_n", where n is a number that increments
every time a file is created.

Note, this is different from initialising data in a file, as a totally new file is created.
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Open Existing File

When the Open ... option from the File menu or the  button on the Toolbar is selected, the following dialog
will appear allowing a file to be selected.

summit.factory checks to ensure that the selected file contains valid Peak/Summit formatted data, and an
error dialog will appear if the file is not valid.

If a file selected for opening is already open, summit.factory will ask if you want to replace the file that is in
memory.
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Save Open Files

The saving of files is only available if summit.factory is registered.

When you save a file to disk using: the Save As ... command from the File Menu, or when a file created using
the New ... command from the File Menu is saved for the first time, the following dialog appears to allow you
to select a name for the file.
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Workspaces

summit.factory allows you to save the current size and position of the main summit.factory window, and the
arrangement of the open Child Windows within summit.factory to a file known as a Workspace.

This allows you to save a Workspace you are using for future recall at a later date.

The following parameters for each Child Window are remembered:

Window size, position and status (normal, maximised or minimised)• 
Horizontal/Vertical Splits, including split position• 
Pane type(s) (e.g. Tree, Voice Table or Performance Table)• 
Tree node expansion status• 
Table column widths• 
Scroll position of the pane(s)• 
Selection state of the tree nodes, or table rows• 
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Export Data

summit.factory allows you to export the data in the currently selected file to a variety of different formats.

HTML• 
XML• 
SpreadSheetML• 

HTML ...

This option allows you to export a listing of the data in HTML format.

XML ...

This option allows you to export a listing of the data in XML format.

This export option is intended to provide a means of importing Peak/Summit data into other programmes, e.g.
a database

 SpreadSheetML ...

This option allows you to export a listing of the data in Microsoft SpreadSheetML format.

This export option is intended to provide a means of importing Peak/Summit data into either Microsoft Word or
Excel, which is a great way to start documenting your program collections.
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Undo Buffer
summit.factory supports a multi-level Undo/Redo Buffer facility on all edits.

The number of edits which can be stored is 100.

The Undo/Redo commands can be found both within the Edit Menu, and on the Toolbar.

Please note that the undo buffer is global across all open files, and is cleared when any file is closed. This
may be improved in later releases.

The undo buffer can be cleared by the selecting the Clear Undo Buffer option on the Edit Menu. The
intention of this feature is to help cope with low memory situations, as it will free up the memory used by
stored edits.
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Clipboard Support
The clipboard works just like the clipboard in other applications. It allows you to place an Object or a copy of
an Object upon the clipboard and then paste that Object elsewhere within a file or another file.

You can Cut/Copy either a single Object or a Collection of Objects onto the clipboard.

You can only paste from the clipboard to the current location in a file if it makes sense to do so. For example:

You cannot paste a Play List onto a Patch• 
You cannot paste ten Patches at the end of a Patch Collection if the selection is at Patch 118 or
higher

• 

The clipboard is "local" to the application, and only Objects can be placed upon it.

summit.factory does not support the system clipboard so it is not possible to cut and paste between and other
applications. I don't think this is a major drawback because I cannot think of any circumstances where you
would wish to do this!
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MIDI Support
To use summit.factory MIDI Export support, your copy of summit.factory needs to be registered.

Configuring MIDI Support

To configure MIDI support, go to the MIDI Preferences tab in the Preferences Dialog, and set up the following:

Input MIDI Port and Output MIDI Port should be set to the MIDI port(s) to which the Peak/Summit is
connected

• 

MIDI Channel should match the Peak/Summit MIDI Channel Global Parameters Setting • 

If the Device Number on the Peak/Summit is set to  ALL then it will accept data for any Device.

You can check that these settings work by pressing the Test Peak/Summit MIDI Settings button. When you
press this button a test message is sent to the Peak/Summit and the subsequent Dialog will tell you if
communication was successful or if there was a problem.

The above steps set up the basic communication mechanism for MIDI support, and you then can set up the
remaining options according to your preferences:

If you never work with Play Lists then you can exclude them from the bulk transfers by clearing the
Include Play Lists in Bulk Transfer checkbox

• 

If you wish for summit.factory to always read the Peak/Summit Program/Play Lists on startup then
check the Read Peak/Summit MIDI Data on Startup checkbox

• 

If you wish for changes made to the Peak/Summit Synthesizer Window to be automatically written to
the Peak/Summit then check the Automatically Update Peak/Summit after Synth Window Edit
checkbox

• 

The Transmit Buffer Size, Transmit Delay Between Buffers and Transmit Delay Between Objects values
define how summit.factory sends data to the Peak/Summit by dividing the data into packets the size of which
are specified by the Transmit Buffer Size value. When summit.factory sends a packet it waits for the time
period specified by Transmit Delay Between Buffers before sending the next packet, and it waits for the
time period specified by Transmit Delay Between Objects after the last packet is sent. The delay
parameters are specified in milliseconds.

You may need to adjust these values (smaller buffers, longer delays) if communications is not reliable, and
you may if you wish adjust these values (larger buffers, smaller delays) to maximise data transfer
performance. If you adjust these values, please ensure that you test the transfer to ensure it is reliable,
otherwise you may risk losing data. Note: Some MIDI interfaces do not like large packet sizes: In 2006 I
upgraded to a MOTU interface and ran into problems with MIDI export until I altered the x.factory MIDI
functions to send messages in small chunks defined by the above parameters!

Copying/Moving Programs and Play Lists

In operation, using MIDI is quite straightforward.

You can get all the Peak/Summit Programs/Play Lists into any Child Window (including the Peak/Summit
Synthesizer Window) by selecting the Import from MIDI option on the MIDI Menu, or the     button on
the Tool Bar.

This imports all Programs, and all Play Lists if you have set the MIDI Preferences options to include Play Lists
during the bulk transfers.

Similarly you can also export all Programs and Play Lists using the Export MIDI option on the MIDI Menu, or
the     button on the Tool Bar.

Note if you import or export MIDI data to/from a Child Window which is opened from a data file, then
the Peak/Summit Synthesizer Window is also updated with the Programs/Play Lists being imported/exported.

And you can also move/copy Programs/Play Lists between the Peak/Summit Synthesizer Window and Child
Window using drag and drop.

You can also import/export a Program or Play List to/from the Peak/Summit Edit Buffer by selecting a single
Program/Play List and selecting the import/export to/from Peak/Summit Edit Buffer options from the Program's
or Play List's Context Sensitive Menu. You can also use the keyboard shortcuts for doing this

Exporting Programs from summit.factory to the Peak/Summit Edit Buffer is really handy, for example, when
trying to find a particular Program in a file and you don't wish to load it into the Peak/Summit.
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Finally you can also perform all the operations on Programs/Play Lists in the Peak/Summit Synthesizer
Window that you can upon Programs/Play Lists in a normal Child Window.

If you have the Automatically Update Peak/Summit after Synth Window Edit option active, when you
change data the Peak/Summit Synthesizer Window then the changes are automatically exported to the
Peak/Summit. 

So you may wish to turn the  Automatically Update Peak/Summit after Synth Window Edit option off
during intensive editing sessions. Once you've made all your changes you then select the Export MIDI option
on the MIDI Menu, or the     button on the Tool Bar  Export option to manually export the changes.

If you quit summit.factory with changes still present in the Peak/Summit Synthesizer Window that have not
been exported, then you will be asked if you wish to export the data or not.

MIDI Keyboard Routing

summit.factory has a facility to allow MIDI data from an additional MIDI input port, defined in the MIDI
Preferences dialog, to be routed to the port you have selected for summit.factory to output MIDI data on. This
allows, for example, you to use a master keyboard (which may be closer to your computer) to be used when
auditioning Peak/Summit sounds that you've sent from summit.factory to the Peak/Summit edit buffer.

You access this feature by selecting the Peak/Summit MIDI Router ... option in the  MIDI Menu or by
pressing the F12 function key whenever you need it, which activates the following dialog.

The router uses the MIDI channel defined in the MIDI Preferences dialog This can either be the channel
transmitted by the source device, or the specified channel.

The routing is active until you close the dialog by selecting the Close Channel button or by pressing the ESC
key.
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Library Support
To use the summit.factory Library, your copy of summit.factory needs to be registered.

Configuring the Library

To configure the Library, go to the Library Preferences tab in the Preferences Dialog, and set up the
preferences for the Library.

Adding Objects to The Library

The following Objects can be added to the Library.

Patches• 
Multis• 

You can add Objects to the Library using the following methods:

Use the Add To Library function that can be found in an Object's context menu;• 
Drag Copy an Object or Selection of Objects over the Summit Library Window.• 
Using the copy and paste functions of the Clipboard.• 

Please note that you can only Drag Copy Objects to the Summit Library Window; you cannot Drag Move
them.

If an object is copied to the Library and it is already present in the library (either a complete match or just a
match in name), then the actions you have configured in the Library Preferences tab in the Preferences Dialog
are taken.

You can also Batch Import files to the library

Copying Objects From The Library

You can copy Objects from the Library to a file using the following methods:

Drag Copy an Object or Selection of Objects from the the Summit Library Window to a file.• 
Using the copy and paste functions of the Clipboard to copy an object from the Summit Library
Window and paste it to a destination file.

• 

Deleting Objects From The Library

To delete an object from the library, right click over the Object or selection of Objects and select the Delete
option from the context menu

Exporting Patches and Multis From The Library to the Summit

You can send Patches and Multis from the Library to the Summit edit buffer by right clicking over a selected
object and selecting the Export to Summit Edit Buffer option from the context menu.

You can also Drag Copy an Object or Selection of Objects from the the Summit Library Window to the Summit
Synth Window

If you check the Automatically Export Selected Item option, then when you select a Patch or Multi it is
automatically exported to the Peak/Summit Edit Buffer.

This, for example, allows you use the cursor keys to move though the library Voices and have them
automatically exported to the Edit Buffer without having to do anything else. Please note however, that with
this option enabled, then the scrolling is slowed down.

You can also double click on a Patch or Multi in the Library Window, and this will export the Patch or Multi to
the Peak/Summit Edit Buffer. A triple click performs the same action and also opens the MIDI Router.

Extracting Files from the Library

If you set the Library Table View to show Files, you can right click over a file and select the Extract File menu
option, which will recreate the original file from all the source data held in the database. The file can then be
saved. This option is also available for Files shown in the Library Tree View

List File Usage

If you right click over an object in the Library, and select the List File Usage... menu option, a dialog will be
displayed which shows all the files in the Library that make use of that object.
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Several files may refer to a single object based on the setting on the Library import preferences if they are set
not to add identical objects. If this is set only a single copy is stored, and all files that contained the identical
object only refer to that single object within the Library

New Author

If you set the Library Table View to show Authors, you can right click in the Table and select the New Author
menu option, which displays a dialog that allows you to create a new Author. This option is also available in
the Library Tree View by right clicking over the Author branch

Library Information ...

Opens the Library Statistics dialog.
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Find and Goto Facilities
Find Dialog

summit.factory supports the ability to find Objects either by name or by category (where an Object supports
categories, such as Voices).

Searches start from the currently selected Object.

Selecting the Find ... option on the Edit Menu brings up the Find dialog, that allows you to specify the string to
search for. In addition there are several options that can be selected

Find What The text string to search for.
Match Case If this option is checked then the search is case sensitive. If this option is not checked then

the search is case insensitive.
Match Whole
Name

If this option is checked then the search string must match the entire name of an Object.
E.g. "pan" would match a Voice called "pan", but not a Voice called "pandora". If this option
is not checked then the search can match a sub string within a name. E.g. "dor" would
match a Voice named "dor" and a Voice called "pandora".

Use Wild Cards If checked summit.factory will treat the "Find What" text as a "regular expression" to allow
you more control over the search, such as matching text at the start of a name, or the end
of a name, words with numbers in, etc.

The regular expression language used for summit.factory wild card support is the Perl Regular Expression
Syntax. Rather than try and write up this powerful syntax myself into the summit.factory documents, I'll direct
you to the Perl Regular Expression Syntax page for a description of how to use this powerful feature.

Find Category Dialog

You can also search by category be selecting Find Category ... option on the Edit Menu, which brings up the
Find Category Dialog.

This option allows you to search, for example, for all string Voices in a file (assuming all Voices have been
assigned a category). Note: only some Objects (such as Voices and Performances) have a category value.

Simply select the Category from the "Find Category" combo box that you wish to search for, and that's all
there is to it.

Goto Dialog

Selecting this option on the on the Edit Menu brings up the Goto Dialog
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Item Type The type of Object to go to

The list of types of Objects that can be selected depends upon the contents of
the file.

• 

If a Table View is selected then you can only go the type of objects shown by the
Table

• 

Item Number The number of the Object to go to.
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Editing Features
summit.factory supports the following editing features:

General Editing Features• 
Synth Editing Features• 
Program Editing Features• 
Multi Editing Features• 
Settings Editing Features• 
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General Editing Features

summit.factory supports many editing features, some of which are classed as general features that are
applicable to all or most Objects.

The general features are described here in one place for convenience:

Copy/Move Object• 
Initialise Object• 
Rename Object• 
Insert Object• 
Delete Object• 
List Object References• 
Sort Objects• 
Export Objects• 
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Copy/Move Object

summit.factory makes extensive use of drag and drop for copying and moving Objects.

You can drag copy or move Objects within a file or between files, and you can drag single items or multiple
items.

The default drag operation is to move an Object, and there are two types of move operations:

Moving an Object within its Parent Collection (e.g. moving a Patch from location 1 to location 4)• 
Moving an Object to a new Parent Collection (e.g. moving a Patch from one file to another file)• 

When you move an Object to a new Parent Collection then the original Object is removed and replaced with
an initialised Object of the same type.

To copy an Object using drag and drop, you must have the DRAG MODIFIER key held down during the
operation. The DRAG MODIFIER key is platform dependent. On the PC platform it is the CTRL key.

You can tell that a copy operation is in progress as the drag image icon has a + sign visible.

When you drag multiple items they must be of the same type. For example you can drag several Patches, but
not Patches and Play Lists together.

summit.factory provides the following drag/drop feedback to assist in determining the effects of a drag/drop
operation:

Cursor: Indicates if the move is either a copy or a move, or if the drop is invalid (e.g. trying to drag a
Patch onto a Play List)

• 

Drag image: A simple pictorial representation of what is being dragged• 
Drop Point: summit.factory shows the drop point as either a cue line drawn between Objects if an
Object is being moved within its parent (e.g. a Patch within a Patch bank), or a cue rectangle drawn
around the drop location for all other moves and copy operations which are valid

• 

When a Child Window is split, Objects can be dragged and dropped between either side of the split point. This
is handy, for example, for dragging Objects between the start of a Collection and the end of a Collection.

The Tree and Table views will auto-scroll in drag and drop operations, when you move the cursor to either the
top or the bottom of the pane and hold it there.

If you drag an Object onto a Tree View and over a valid parent Object (e.g. a Patch over a Patch Collection)
and the parent Object is collapsed within the Tree, and you hold the cursor over the Parent Object for a few
seconds it will automatically expand.

Initialise Object

Initialises the selected Object to its default state.

Multiple Objects of the same type can be selected for initialisation.

The Initialise command is found upon the Context Sensitive Menu in both the Tree View and the Table
View.

Rename Object

Renames the selected Object using the following dialog:

Only one Object can be selected for renaming.

The Rename command is found upon the Context Sensitive Menu in the Tree View

When renaming Peak/Summit Patches, you have the option to both edit the name and change the Patch
Category. For Summit Multis, a Mulit does not have a category but you can edit the name and category for
each of the two Multi Layers

To rename Objects in the Table View, simply click in Category Cell of the required Object to select the
Category value from a drop down list (for Patches and Multi Layers), or double click in the Name Cell of the
required Object to edit the name.
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Insert Object

Inserts an Object into a Collection at the current location.

The Insert command is found upon the Context Sensitive Menu in both the Tree View and the Table View.

You can insert more than one Object at a time by selecting multiple Objects prior to executing the Insert
command.

For example if you wish to insert three Patches at location 10, select Patches 10, 11 and 12 and then execute
the Insert command.

Note that when you insert one or more Objects, then the commensurate number of Objects at the end of the
Parent Collection are removed if required. This is necessary to maintain the correct number of Objects in a
Collection.

For example, a Patch Collection can only contain 128 Patches, so if two Patches are inserted into the
Collection then two Patches must be removed from the end of the Collection to maintain the correct size.

Delete Object

Deletes an Object at the current location.

The Delete command is found upon the Context Sensitive Menu in both the Tree View and the Table View.

You can delete more than one Object at a time by selecting multiple Objects prior to executing the Delete
command.

For example if you wish to delete three Patches at location 10, select Multis 10, 11 and 12 and then execute
the Delete command.

Note that when you delete one or more Objects, then a commensurate number of Objects at the end of the
Parent Collection are added if required. This is necessary to maintain the correct number of Objects in a
Collection.

For example, a Patch Bank Collection must contain 128 Patches, so if two Patches are deleted from the
Collection then two Patches must be added to the end of the Collection to maintain the correct size.

Sort Objects

The Sort by Name and Sort By Category commands are found upon the Context Sensitive Menu in both
the Tree View and the Table View.

In the Tree View the sort options are accessed via the Patch Sensitive Menu for the Collection that you wish
to sort (e.g. a Patch Bank Collection to sort Programs).

In the Table View the sort options are accessed via the Context Sensitive Menu for any Object. The sort can
also be initiated by clicking in the Name or Category column headers.

Synth Editing Features

summit.factory supports the following editing operations upon the Synth Object within the Tree View of
a Child Window:

Move• 
Copy• 
Initialise• 
Add - If not all main collections are present in the file (e.g. Patch Banks, Multi Banks, etc.) then this
menu will be present allowing you to add in the items that are not present

• 

Import From Peak/Summit Memory• 
Export To Peak/Summit Memory (only available if summit.factory is registered) • 

Import from Peak/Summit Memory

Imports Patches, Multis and System Settings from the Peak/Summit Memory locations into the
currently selected Child Window.

If a data object does not existing in the file then it is not imported. Multis and System Settings will be
ignored unless the relevant options in the MIDI Preferences dialog are checked.

Export to Peak/Summit Memory

Exports Patches, Multis and System Settings from the currently selected Child Window to the
Peak/Summit Memory locations.
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If a data object does not existing in the file then it is not exported. Multis and System Settings will be
ignored unless the relevant options in the MIDI Preferences dialog are checked.

To access these features, right click over the Synth Object to activate the Synth Object's Context Sensitive
Menu.

The Synth Object is only shown within a Tree View and is the first Object in the Tree View.
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Patch Editing Features

Patch Bank Collection Editing Features

summit.factory supports the following editing operations upon the Patch Bank Collection shown within
the Tree View or Table View of a Child Window:

Copy/Move• 
Initialise• 
Delete• 
Add Patch Bank - if there are unused banks within the file, then the unused bank names are
presented as sub menu items for selection to create a new bank

• 

Import From Peak/Summit Memory• 
Export To Peak/Summit Memory (only available if summit.factory is registered) • 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Collection to activate the Patch Collection's Context Sensitive Menu.

Patch Bank Editing Features

summit.factory supports the following editing operations upon the Patch Banks shown within the Tree View
or Table View of a Child Window:

Copy/Move• 
Initialise• 
Renumber - if there are unused banks within the file, then the unused bank numbers are presented as
sub menu items for selection to allow this bank to be renumbered

• 

Delete• 
Sort by Name• 
Import From Peak/Summit Memory• 
Export To Peak/Summit Memory (only available if summit.factory is registered) • 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Collection to activate the Patch Collection's Context Sensitive Menu.

Patch Editing Features

summit.factory supports the following editing operations upon the Patch Objects within the Tree View
or Table View of a Child Window:

Copy/Move• 
Initialise• 
Rename• 
Insert• 
Delete• 
Import From Peak/Summit Memory• 
Export To Peak/Summit Memory (only available if summit.factory is registered) • 
Import from Peak/Summit Edit Buffer• 
Export to Peak/Summit Edit Buffer (only if available summit.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
or selection of Patchs to activate the Patch's Context Sensitive Menu.

Import from Peak/Summit Memory

Imports Patchs from the Peak/Summit Memory locations into the currently selected Child Window.

Export to Peak/Summit Memory

Exports Patchs from the currently selected Child Window to the Peak/Summit Memory locations.

Import from Peak/Summit Edit Buffer

Imports the Patch currently in the Peak/Summit Edit Buffer (i.e. the currently selected Patch on the
Peak/Summit) into the Patch currently selected within the active Child Window.
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Note if you have more than one Patch selected then this operation is not available

Export to Peak/Summit Edit Buffer

Exports the Patch currently selected within the active Child Window to the Peak/SummitPropht X Edit Buffer.

Note if you have more than one Patch selected then this operation is not available

Multi editing options are only available in Summit SYSEX files, and the MIDI options are only available if the
Synth Type in the MIDI Preferences tab in the Preferences Dialog is set to Summit.

Multi Editing Features

Multi Bank Collection Editing Features

summit.factory supports the following editing operations upon the Multi Bank Collection shown within
the Tree View or Table View of a Child Window:

Copy/Move• 
Initialise• 
Delete• 
Add Multi Bank - if there are unused banks within the file, then the unused bank names are presented
as sub menu items for selection to create a new bank

• 

Import From Summit Memory• 
Export To Summit Memory (only available if summit.factory is registered) • 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Multi Collection to activate the Multi Collection's Context Sensitive Menu.

Multi Bank Editing Features

summit.factory supports the following editing operations upon the Multi Banks shown within the Tree View
or Table View of a Child Window:

Copy/Move• 
Initialise• 
Renumber - if there are unused banks within the file, then the unused bank numbers are presented as
sub menu items for selection to allow this bank to be renumbered

• 

Delete• 
Sort by Name• 
Import From Summit Memory• 
Export To Summit Memory (only available if summit.factory is registered) • 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Multi Collection to activate the Multi Collection's Context Sensitive Menu.

Multi Editing Features

summit.factory supports the following editing operations upon the Multi Objects within the Tree View or Table
View of a Child Window:

Copy/Move• 
Initialise• 
Rename• 
Insert• 
Delete• 
Import From Summit Memory• 
Export To Summit Memory (only available if summit.factory is registered) • 
Import from Summit Edit Buffer• 
Export to Summit Edit Buffer (only if available summit.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Multi
or selection of Multis to activate the Multi's Context Sensitive Menu.
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Multi Layer Editing Features

summit.factory supports the following editing operations upon the Multi Layer Objects within the Tree View
or Table View of a Child Window:

Copy/Move• 
Initialise• 
Rename• 
Insert• 
Delete• 
Import from Summit Edit Buffer• 
Export to Summit Edit Buffer (only if available summit.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Multi
or selection of Multis to activate the Multi's Context Sensitive Menu.

A Multi Layer is a Patch, so Drag and Drop also works between Patches and Multi Layers.

Import from Summit Memory

Imports Multis from the Summit Memory locations into the currently selected Child Window.

Export to Summit Memory

Exports Multis from the currently selected Child Window to the Summit Memory locations.

Import from Summit Edit Buffer

Imports the Multi currently in the Summit Edit Buffer (i.e. the currently selected Multi on the Summit) into the
Multi currently selected within the active Child Window.

Note if you have more than one Multi selected then this operation is not available

Export to Summit Edit Buffer

Exports the Multi currently selected within the active Child Window to the SummitPropht X Edit Buffer.

Note if you have more than one Multi selected then this operation is not available

System Settings Editing Features

px.factory supports the following editing operations upon the System Settings Object shown within the Tree
View or Table View of a Child Window:

Copy/Move• 
Initialise• 
Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
System Settings Object to activate the System Settings Object's Context Sensitive Menu.

Library Statistics

The Library Statistics menu option is found on the Tools menu.

This feature is only available if your copy of summit.factory is registered.

The Library Statistics Dialog provides a means for you to see a summary of the contents of the Library.
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Batch Import To Library

The Batch Import To Library Wizard is found on the Tools menu.

This feature is only available if your copy of summit.factory is registered.

The Batch Import To Library Wizard provides a means for you to import several Peak/Summit files to the
library in one go.

The Batch Import To Library Wizard has two pages to navigate through:

The Select Source Directory Page• 
The Select Destination Directory Page• 

Select Source Directory Page

The Select Source Directory Page is shown below

This page has the following options

Source Directory You can type the name of the source directory in this control.

Or if you click the [...] button to the right of the line, this will bring up a file
selector dialog.

Scan Subdirectories If this control is checked, then the Batch Converter will also include any
subdirectories that it finds within the source directory when looking for
files to convert.

If this control is not checked then any subdirectories in the source
directory will be ignored.

Ignore File Errors If this control is not checked then any errors detected during file loading
will halt the conversion process.

If this control is checked then these errors are ignored, but are logged if
logging is enabled.
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Select Destination Directory Page

The Select Destination Directory Page is shown below

This page has the following options

When an Object being added is
already in the Library

Provides the action to do if an Object is added to the Library and there is
already an identical Object in the library. The choices are:

Add to Library (with a new name)• 
Do not add to Library• 
Overwrite Object in the Library• 

When an Object being added
already has the same name as an
Object in the Library

Provides the action to do if an Object is added to the Library and there is
already an Object in the library with the same name. The choices are:

Add to Library (with a new name)• 
Do not add to Library• 
Overwrite Object in the Library• 

Create Log File If this control is checked then a log file is created in the destination
directory.

This log file is called "Log File.txt", and can be opened with any text
editor

Using the Batch Importer

Using the importer is quite simple.

Importing a Peak/Summit file takes about 10 seconds, so if you have a lot of files to import, be prepared to
leave the importer running for a while! The import of a file will be slower if you have a large library as
summit.factory needs to check for duplicate data, so the larger the library the more data the batch importer
has to search.

The importer is a simple "Wizard" and you can step through the choice pages using the Prev and Next
buttons, or exit the Wizard using the Cancel Button

Select the source and destination directory options and once that is done click on the Finish button to start
the Batch Import Wizard.

The Wizard will not allow you to select a directory that doesn't exist.

Once the Wizard starts the progress of importing files is shown in the information pane.
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There is a progress bar that shows the progress for all the files that the importer has detected, and a progress
bar for the objects in the file currently being imported.

The Wizard also shows how many file errors have been encountered (assuming you have set the options to
ignore File errors).

You can cancel the import at any time by pressing the Cancel button, but you may need to wait for
summit.factory to finish the current file import before the batch conversion is cancelled.

Once completed, a summary results page is shown that summarises the import.

The Wizard can be dismissed by clicking the Close button.

You can check the results of the import by opening the Log File.txt file (assuming you left logging enabled).

The log file is a simple text file that lists each source file and whether any errors were detected.

All errors are preceded by ** (two stars), so you can use your text editor's find/search facilities to look for ** to
quickly find any errors.
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Preferences
The summit.factory preferences are accessed via the Preferences ... option on the View menu or the
summit.factory Application Menu on OS X, or the  button on the Toolbar.

Selecting this option opens a Tabbed dialog with the following tabs which group related parameters:

New File Preferences• 
Check Preferences• 
Default View Preferences• 
Summit MIDI Preferences• 
Library Preferences• 
Miscellaneous Preferences• 

To view and modify a set of parameters, click on the relevant tab.
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New File Default Preferences
The New File Default Preferences tab is shown below:

This tab has the following options, with the Multi Bank options only being visible if the Device Type setting in
theÂ MIDI Preferences tab in the Preferences Dialog is set to Summit

Patch Bank A When checked the Patch Bank A checkbox in the New File Dialog will
be initially checked when the Dialog is opened.

Patch Bank B When checked the Patch Bank B checkbox in the New File Dialog will
be initially checked when the Dialog is opened.

Patch Bank C When checked the Patch Bank C checkbox in the New File Dialog will
be initially checked when the Dialog is opened.

Patch Bank D When checked the Patch Bank D checkbox in the New File Dialog will
be initially checked when the Dialog is opened.

All Selects all Patch Bank options in one operation.
None Clears all Patch Bank options in one operation.
Multi Bank A When checked the Multi Bank A checkbox in the New File Dialog will be

initially checked when the Dialog is opened.
Multi Bank B When checked the Multi Bank B checkbox in the New File Dialog will be

initially checked when the Dialog is opened.
Multi Bank C When checked the Multi Bank C checkbox in the New File Dialog will be

initially checked when the Dialog is opened.
Multi Bank D When checked the Multi Bank D checkbox in the New File Dialog will be

initially checked when the Dialog is opened.
All Selects all Multi Bank options in one operation.
None Clears all Multi Bank options in one operation.
System Settings When checked the System Settings checkbox in the New File Dialog

will be initially checked when the Dialog is opened.
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Check Preferences
The Check Preferences tab is shown below:

This tab has the following options:

Check For Duplicates When
Moving or Copying Objects

If you move or copy an Object to a destination file and the Object already
exists then a warning is presented giving you the option to continue or
cancel the operation.

Warn if Destination Object is
Referenced When Moving or
Copying Objects

If you move or copy an Object and it is overwriting an Object that is
being referenced, or you are deleting a referenced Object, then a
warning is presented giving you the option to continue or cancel the
operation.
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Default View Preferences
The Default View Preferences tab is shown below:

Default View Defines the type of view that is applied to a Child Window when it is first
opened.

The following options are available:

No Split• 
Horizontal Split• 
Vertical Split• 

Pane/Left Pane/Top Pane Defines the type of view shown in the single pane of an unsplit view, the
left pane of a horizontally split view or the top pane of a vertically split
view.

The following options are available:

Tree View• 
Table View• 

Right Pane/Bottom Pane This control is only visible if the Default View option is set to either
Horizontal Split or Vertical Split.

Defines the type of view shown in the right pane of a horizontally split
view or the bottom pane of a vertically split view.

The following options are available:

Tree View• 
Table View• 

View Tool Bar Controls if the toolbar is visible at startup.
View Status Bar Controls if the status bar is visible at startup.
View Backdrop In Child Window This option controls if the image backdrop is displayed in Child Windows.

You may wish to turn off this option if you find the scrolling of the Child
Window is slow on your machine.
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MIDI Preferences
The MIDI Preferences tab is shown below:

This tab has the following options:

Device Type Sets the Device Type to be either a Peak or a Summit. Set according to the
Device type that you are connecting to.

Keyboard Input MIDI Port Sets the port used for accepting MIDI data from a keyboard and routing it to
the output MIDI port using the MIDI Router Dialog.

Keyboard Input MIDI
Channel

Sets the channel to be used for transmitting MIDI data using the MIDI Router
Dialog. The first option Use Source Channel in the drop down list, means that
the MIDI channel from the source device is not altered.

Input MIDI Port Sets the port used for MIDI input from the available ports.
Output MIDI Port Sets the port used for MIDI output from the available ports.
Timeout Delay Sets the time that summit.factory waits for a response from the Peak/Summit

before timing out and reporting an error. The value is specified in milliseconds.
Transmit Buffer Size Sets the size of the transmit buffer used for sending data to the Peak/Summit.

Some MIDI interfaces don't like data coming in big chunks and you may need
to set this to get a reliable transfer of data. The value is specified in
milliseconds.

Transmit Delay Between
Buffers

This sets the delay that summit.factory waits for between sending buffer sized
data packets. The value is specified in milliseconds.

Transmit Delay Between
Objects

This sets the delay that summit.factory waits for after sending a complete
object. The value is specified in milliseconds.

Automatically Update
Peak/Summit after Synth
Window Edit

When this option is checked, if the Peak/Summit Synthesizer Window is edited
then the edited data will be automatically sent to the Peak/Summit.

Read Peak/Summit MIDI
Data On summit.factory
Startup

When this option is checked the Programs and Play Lists (if enabled) are read
from the Peak/Summit during the summit.factory startup phase.

Include Multis In Bulk
Transfer

When this option is checked, the Summit Multis are included in bulk transfers.
You may wish to uncheck this option if you don't use Multis.

Include System Settings In
Bulk Transfer

When this option is checked, the System Settings are included in bulk
transfers. You may wish to uncheck this option if you don't wish to store
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System Settings in your files.
Test Peak/Summit MIDI
Settings

Tests to see if MIDI communications is working using the specified values.
The test:

Sends a Universal SYSEX Device Inquiry message on the specified
MIDI output port

1. 

Waits for a response on the specified MIDI input port. If the response
times out an error message is displayed

2. 

Checks to see if the expected response is received. If not then an
error message is displayed

3. 
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Library Preferences
The Library Preferences tab is shown below:

This tab has the following options:

When an Object being added is
already in the Library

Provides the action to do if an Object is added to the Library and there is
already an identical Object in the library. The choices are:

Add to Library (with a new name)• 
Do not add to Library• 
Overwrite Object in the Library• 
Ask What To Do• 

When an Object being added
already has the same name as an
Object in the Library

Provides the action to do if an Object is added to the Library and there is
already an Object in the library with the same name. The choices are:

Add to Library (with a new name)• 
Do not add to Library• 
Overwrite Object in the Library• 
Ask What To Do• 

Copy Referenced Objects to
Library

If this Option is checked, then any Objects being referenced by an
Object being added to the Library are also added to the Library.

Prompt for Author of File When
Adding a File

If this Option is checked then summit.factory will ask for the Author of the
file if one has not already been entered.

Default Filter for Rating Column Sets the default filter type for the Rating column. The choices are:

Regular Expression (can contain Perl Regular Expressions)• 
Match Value (can only be selected using an existing value)• 
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Default Filter for the Comment
Column

Sets the default filter type for the Comment column. The choices are:

Regular Expression (can contain Perl Regular Expressions)• 
Match Value (can only be selected using an existing value)• 

Default Filter for the Author
Column

Sets the default filter type for the Author column. The choices are:

Regular Expression (can contain Perl Regular Expressions)• 
Match Value (can only be selected using an existing value)• 

Default Filter for the Source
Column

Sets the default filter type for the Source column. The choices are:

Regular Expression (can contain Perl Regular Expressions)• 
Match Value (can only be selected using an existing value)• 
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Miscellaneous Preferences
The Miscellaneous Preferences tab is shown below:

This tab has the following options:

Startup Directory Allows the startup directory to be specified. Note: no validation is
performed on this pathname, so please ensure it is valid. I may add
validation later.

The [...] button to the right of the field brings up a dialog that allows you
to select the directory instead of typing it in.

Load Last File On Startup Controls if the last file opened in the previous session is automatically
loaded when summit.factory is next invoked.

Enable MIDI Logging When checked, MIDI communications is logged to the summit.factory log
file. Only turn this on when you need to, as the amount of data being
written to the logs will slow down MIDI operations. This option is reset
everytime summit.factory starts, so you need to enable it in each session
if you wish to use it.
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Online Help
summit.factory provides a full online version of the summit.factory manual.

If you select Help ... from the Help Menu or the  button on the Tool Bar, the Help Window is opened.

The Help Window works just like a web browser window, so its operation should be quite familiar to you.

The left pane of the Help Window shows a tabbed navigation pane to allow you to quickly navigate to a topic,
whilst the right hand pane shows the help topic.

The navigation pane can show three different views, depending on which tab you select:

   Displays the Table of Contents Navigation Pane, providing a structured list of summit.factory
topics

• 

   Displays the Index Navigation Pane, providing an indexed list of summit.factory topics• 
   Displays the Search Navigation Pane, allowing you to search the help topics for keywords• 

The Help Window has the following Tool Bar buttons:

   Navigates backwards to the last page in the access sequence. If you press and hold the mouse
button over this button, you will get a list of accessed pages

• 

   Navigates forwards to the next page in the access sequence. If you press and hold the mouse
button over this button, you will get a list of accessed pages

• 

   Selects the home page• 
    Refreshes the current page• 
    Prints the current page• 
    Displays the print settings dialog• 

Context Sensitive Help
You can access context sensitive help by:
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pressing the your Computer Platform's Help Key ( F1 on the PC platform), which will load the help
page associated with the Component within the summit.factory Window that currently has Focus (is
responding to the keyboard and mouse).

• 

pressing the  button on the Tool Bar and the clicking over the item of interest• 

You can press the Help Key in any summit.factory Dialog to access the relevant help page for the Dialog.
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Tips and Tricks
The summit.factory tips and tricks dialog is shown below:

This dialog has the following controls:

Close Closes the Tips and Tricks Dialog
Next Tip Selects the next tip in sequence
Show Tips at
Startup

If checked then when summit.factory starts up, the Tips and Tricks Dialog is automatically
opened

List of Tips and Tricks
Just in case you want the tips and tricks shown by the dialog as one single list, here they are.

Context Sensitive Help

If you press the Help Key ( F1 on a PC) then you can get context sensitive help, including within Dialogs.

Keyboard Shortcuts

summit.factory supports numerous keyboard shortcuts as an alternative to using the mouse.

Take a look in the online help or the summit.factory manual for details of the supported keyboard shortcuts

Object Colouring

If an Object such as a Wave or Patch is coloured blue, then it is being referenced by another Object.

If you right click over a blue Object you'll find a "List References" context menu, which will show you the
Objects that reference this one.

Find/Find Next Category Tool Bar Buttons

If you hold the SHIFT key down whilst pressing the Find or Find Next tool bar button the operations
performed change from:

Find to Find Category• 
Find Next to Find Next Category• 

Table Sorting

You can sort Tables by clicking in the Table Column headers.

For example, if you click in the Name Column then the Table will be sorted by Name

You can only DRAG COPY Certain Objects

If you are trying to perform a drag operation on certain data types and are wondering why summit.factory is
not allowing you to perform the drag, try holding down the CTRL key during the drag to see if this is then
allowed. Holding down the CTRL key turns the operation from a Drag Move operation to a Drag Copy
operation.

Sometimes during a drag operation, the only sensible operation that can be undertaken is a copy operation,
for example:
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Copying/Moving Objects to a Different File

When you copy an Object to a different file then any Objects it references can also be copied at the same
time.

For example of you move a Play List entry to a new File, then the referenced Patch is also copied (assuming
they are present within the file):

I think you'll agree this is a cool feature!

This feature can be selectively turned off for different Object types if required within the Preferences Dialog.

Workspaces

summit.factory allows you to save a Window arrangement as a Workspace which you can then recall at a
later date.
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About summit.factory
The about dialog is shown when the About ... option from the Help Menu or the  button on the Tool Bar is
selected.

The dialog shows some basic information about the program including the version number and the License
status of summit.factory.

It also shows which Java Run Time Environment that summit.factory is running in.
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Glossary
Term Definition
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Keyboard Short Cuts
summit.factory provides many keyboard shortcuts for navigation and performing editing operations.

In general, navigating between components uses these keys:

Tab. Moves keyboard focus to the next component or to the first member of the next group of
components.

• 

Ctrl-Tab. Moves keyboard focus to the next component or to the first member of a group of
components when the current component accepts a tab (as in text fields, tables, and tabbed panes).

• 

Shift-Tab. Moves keyboard focus to the previous component or to the first component in the previous
group of components.

• 

Arrow keys. Move keyboard focus within the individual components of a group of components--for
example, within menu items in a menu or within tabs in a tabbed pane.

• 

The shortcuts are divided into the following categories:

Keyboard shortcuts for the Desktop and Child Wndows• 
Keyboard shortcuts for Tree Views• 
Keyboard shortcuts for Table Views• 
Keyboard shortcuts for Editing within Tree and Table Views• 
Keyboard shortcuts for the Preferences Dialog• 
Keyboard shortcuts for Text Editing Fields• 

Keyboard Shortcuts for the Desktop and Child Windows

Action Keystroke Notes

New File Ctrl-N

Open File Ctrl-O

Save File Ctrl-S

Save File As Ctrl-A

Save All Files Ctrl-L

Open Workspace Ctrl-ALT-O

Save Workspace Ctrl-ALT-S

Tile Horizontally Ctrl-H

Tile Vertically Ctrl-V

Maximise Windows Ctrl-M

Restore Windows Ctrl-R

Minimise Windows Ctrl-I

Closes Child Window Ctrl-F4

Moves Child Window Ctrl-F7

Resizes Child Window Ctrl-F8

Minimizes Child Window Ctrl-F9

Switch to next Child Window on the
Desktop

Ctrl-F6
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Keyboard Shortcuts for Tree Views

Action Keystroke Notes

Expands current Object Right arrow

Collapses current Object, or moves focus
to Parent Object

Left arrow

Moves focus up one Object Up arrow

Moves focus down one Object Down arrow

Moves focus to first Object in Tree View Home

Moves focus to last Object in Tree View End

Moves up one view Page Up

Moves down one view Page Down

Selects all Object in Tree View Ctrl-A, Ctrl-/

Deselects all Object in Tree View Ctrl-\

Extends selection down Shift-down
arrow

Extends selection up Shift-up arrow

Extends selection to beginning of Tree
View

Shift-Home

Extends selection to end of  Tree View Shift-End

Extends selection up one view Shift-PgUp

Extends selection down one view Shift-PgDn
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Keyboard Shortcuts for Table Views

Action Keystroke Notes

Moves up one row Up arrow
Shift-Return

Moves down one row Down arrow
Return 

Scrolls up one view Page Up

Scrolls down one view Page Down

Moves focus and view to first cell in the
current row

Home

Moves focus and view to last cell in the
current row

End

Moves focus and view to first cell in the
current column

Ctrl-Home

Moves focus and view to last cell in the
current column

Ctrl-End

Allows editing in a Category cell F2, Down Arrow

Allows editing in a Name cell. F2

Resets cell to the state it was in before it
was edited

Escape

Selects entire table Ctrl-A

Extends selection up one row Shift-up arrow

Extends selection down one row Shift-down
arrow

Extends selection to beginning of table Ctrl-Shift-Home

Extends selection to end of table Ctrl-Shift-End

Extends selection up one view Shift-PgUp

Extends selection down one view Shift-PgDn
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Keyboard Editing Short Cuts for both Tree and Table Views

Action Keystroke Notes

Undo Ctrl-Z

Redo Ctrl-Y

Cut Ctrl-X

Copy Ctrl-C

Paste Ctrl-V

Find Ctrl-F

Find Next F3

Find Category Ctrl-Shift-F

Find Next Category Shift-F3

Goto Ctrl-G

Insert Object INS Not allowed on
Collections

Delete Object DEL Not allowed on
Collections

Rename Object F4 Single Named Object
Only

Initialise Object F5

List References F6 Single Named Object
Only

Map To Flash F7

Map To Ram Shift-F7

Export to MIDI Edit Buffer F8 Single Voice or
Performance Only

Export to MIDI Memory Shift-F8 Voices or
Performances Only

Import from MIDI Edit Buffer F9 Single Voice or
Performance Only

Import from MIDI Memory Shift-F9 Voices or
Performances Only
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Keyboard Shortcuts for the Preferences Dialog

Action Keystroke Notes

Navigates through tabs Arrow keys

Moves from tab to its associated content
pane

Ctrl-down arrow

Moves from content pane to its
associated tab

Ctrl-up arrow

Keyboard Shortcuts for Text Editing Fields

Action Keystroke Notes

Moves insertion point one character to
the right

Right arrow

Moves insertion point one character to
the left

Left arrow

Moves insertion point to beginning of
next word

Ctrl-right arrow

Moves insertion point to beginning of
previous word

Ctrl-left arrow

Moves insertion point to beginning of
field

Home

Moves insertion point to end of field End

Submits text entry Enter, Return

Extends selection to beginning of line Shift-Home

Extends selection to end of line Shift-End

Extends selection one character to the
left

Shift-left arrow

Extends selection one character to the
right

Shift-right arrow

Extends selection to next word Shift-Ctrl-right
arrow

Extends selection to previous word Shift-Ctrl-left
arrow
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Credits
Thanks go, in no particular order, to:

Sequential for making such a fantastic synthesizer in the Prophet X• 

3rd party software used in summit.factory
The following 3rd part software is used to build summit.factory and provide some program features.

CoreMIDI4J License

summit.factory makes use of CoreMIDI4J to provide MIDI support on OS X, which is issued under the EPL 1.0
License.

Table Filter License

summit.factory makes use of TableFilter by Luis M. Pena, which is issued under the MIT License.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Apache Derby License

summit.factory makes use of Apache Derby to provide the library function, which is issued under the Apache
2.0 License.

Apache Log4J License

summit.factory makes use of Apache Log4J to provide logging services, which is issued under the Apache 2.0
License.

Dom4J License

summit.factory makes use of Dom4J to provide XML services, which is issued under the Maplesoft Dom4J
License.

THIS SOFTWARE IS PROVIDED BY METASTUFF, LTD. AND CONTRIBUTORS ``AS IS'' AND ANY
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL METASTUFF, LTD. OR ITS CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

summit.factory makes use of IzPack to provide the summit.factory installer, which is issued under the Creative
Commons 4.0 License.

Java Wizard License

The summit.factory Library Batch Importer makes use of the Java Wizard Project which is distributed under
the Open Source Initiative Common Development and Distribution License.

I have adapted the Wizard software to allow me to display two progress bars in the Wizard. If anybody wishes
to have the source code for how I did this, please email me at supportx@xfactory-librarians.co.uk and I will
happily provide the adapted source code.

Splash Screen Graphic

The background of the splash screen is an image by rawpixel.com from Freepik
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summit.factory License
The unregistered version of summit.factory allows you to evaluate the features of the program, which are fully
functional except the File Save, MIDI Export and Librarian features.

However, summit.factory cannot be included as part of a commercial distribution or on other web sites without
the express permission of the Author. I am happy for you to provide links to www.xfactory-librarians.co.uk, to
maximise public access to summit.factory.

summit.factory license files are issued to users who have registered summit.factory, to gain access to the File
Save, MIDI Export and Librarian features. If you have been issued with a license key you are not allowed to
distribute a license key to other users. Please respect this, and the amount effort I have put into making this
application.

You are permitted to install and activate summit.factory on two computers, for which the license is valid.

If you wish to install and activate summit.factory on more than two computers, then an additional license can
be purchased at 50% of the cost of the main license.

The Author retains the copyright on the program and all of its originally developed features.

Disclaimer
Like all software products, this software is provided "AS IS", and without any warranties expressed or implied.
But hey, remember, you're getting it for a very low cost!

I have worked hard to ensure this software works correctly, as I certainly don't want it trashing my data.
However, I cannot be held liable for any problems arising as a consequence of you using this software on
your computer and your data. You use this product at your risk.

Like all new products, please proceed and evaluate with care, and ensure that all your important data files are
backed up before installation and evaluation.

Having gotten that out of the way, if you do encounter any problems, please submit a bug report
to support@xfactory-librarians.co.uk, and I will endeavour to provide a fix for any reported problems.

Licensing Conditions for 3rd party software
Apache Derby License

summit.factory makes use of Apache Derby to provide the library function, which is issued under the Apache
2.0 License.

Apache Log4J License

summit.factory makes use of Apache Log4J to provide logging services, which is issued under the Apache 2.0
License.

CoreMIDI4J License

summit.factory makes use of CoreMIDI4J to provide MIDI support on OS X, which is issued under the EPL 1.0
License.

Dom4J License

summit.factory makes use of Dom4J to provide XML services, which is issued under the Maplesoft Dom4J
License.

THIS SOFTWARE IS PROVIDED BY METASTUFF, LTD. AND CONTRIBUTORS ``AS IS'' AND ANY
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL METASTUFF, LTD. OR ITS CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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Java Wizard License

The summit.factory Library Batch Importer makes use of the Java Wizard Project which is distributed under
the Open Source Initiative Common Development and Distribution License.

Table Filter License

summit.factory makes use of TableFilter by Luis M. Pena, which is issued under the MIT License.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Tritonus License

summit.factory makes use of Tritonus Java Sound Extensions, which is issued under the GNU Lesser
General Public License.
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