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What's New in fc.factory 1.2.02 (23/12/2023)
Provided a workaround for the OSX Java file selector bug that reports a non existent directory when
you have double clicked a directory to select it.

• 

Improved registration process. You now no longer have to quit the program to activate the disabled
features once registered and activated.

• 

Application rebuild to stay current with latest version of Java 17, required libraries and build tools.• 

Previous Versions
V1.2.01 (20/12/2022)

Fixed a bug in drag and drop (most noticeable in kronos.factory and montage.factory due to file sizes)
where drag and drop operations were occasionally failing and providing an error message about copy
and paste not being possible.

• 

Fixed a bug where using the View/Refresh menu option killed drag and drop.• 
Updated the status bar's file name display to show a truncated path (with the filename fully visible) if
the the full path will not fit in the available space.

• 

V1.2.00 (08/05/2022)

Updated how the applications are built. The Java Runtime is now embedded and updated to Java 17
as the minimum version. There is no longer a need for a standalone version of Java to be installed

• 

New installers for OS X (DMG), PC (MSI) and Linux (DEB) and basic ZIP and TAR packages.• 
The OS X DMG package is notarized for compatibility with the OS X security model.• 

V1.1.01 (05/07/2020)

Fixed problem on OS X Mojave and Catalina which was preventing access to protected folders.• 

V1.1.00 (18/04/2020)

If you double click on a patch, it will be sent to the synth's edit buffer.• 
The application now supports MIDI data logging to the application log, which can be enabled in the
Preferences/Misc Tab. It is recommended that this is not normally turned on, and it is only needed
when required to help me diagnose any MIDI issues that are reported if you are experiencing any
such issues.

• 

The Minimum Java Version is now Java 11, and I have rebuilt the applications with the latest support
libraries. The migration to Java 11 is a significant step, as I have been help back from migrating to
Java 9 and above due to Java PC MIDI issues that were causing garbled MIDI port names, which
made it impossible to select MIDI ports. These issues are now resolved in the recommended JREs.
Please see the Java Support page on the website for more details.

• 

The applications support iMac Retina displays.• 

V1.0.00 (22/12/2019)

First Release• 

Previous Versions
V0.1.00 (11/09/2019)

Beta release for internal testing• 
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Installation and Configuration of fc.factory
fc.factory is downloaded as a self installing file, so installation is automatic, and for most users little else, if
anything, needs to be done to get up and running.

A native installer for Windows is also available.

This section is only relevant to installing additional items not included as part of the fc.factory installer.

Installing MIDI Extensions for MacOS X
If you wish to use the MIDI support provided on Mac OSX, then a Java MIDI Service Provider extension is
required.

The extensions provide MacOS X Java programs access to all CoreMIDI devices

An extension is required because, historically, the Java implementation on OS X is not able to access external
MIDI devices. Apple/Oracle claim to have fixed the external MIDI device access problem in its Java
implementation. However, it appears that only "simple" MIDI messages are now supported. SYSEX data
transfer (essential for transferring synth data) is not supported.

fc.factory now embeds CoreMIDI4J in the application package, so you no longer need to download and install
it separately. However, if you still require an SPI for other Java MIDI software then you will need to ensure
that you have the latest compatible version of CoreMIDI4J, as if an SPI is installed in the
/Library/Java/Extensions folder then this will override the version of CoreMIDI4J embedded in fc.factory.

If you are not using any other Java software that requires MIDI access, it is best to remove any existing
version of CoreMIDI4J from the /Library/Java/Extensions folder so that fc.factory can access the CoreMIDI4J
version embedded in the package. That way you can ensure that fc.factory is always using the latest
compatible version of CoreMIDI4J.

fc.factory will warn you if it detects an earlier version of CoreMIDI4J. It will still function, but will not benefit
from recent CoreMIDI4J bug fixes or enhancements.

If you need to retain a version of CoreMIDI4J in the /Library/Java/Extensions folder then you can always
download the latest version of CoreMIDI4J.jar from  CoreMIDI4J Releases

Once you have downloaded CoreMIDI4J.jar it needs to be copied to the /Library/Java/Extensions folder. You
will need to provide administrator permissions to copy the files.

Once installed, when running the librarians and selecting the MIDI ports to use, select the ports prefixed with
CoreMIDI4J -. For example my Edirol UA-25 interface that I use for testing on OS X is listed as CoreMIDI4J -
UA-25. The latest version of fc.factory will only list CoreMIDI4J devices.
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Registering fc.factory
You need to register fc.factory to allow MIDI data to be exported to the FC300, and for data to be saved to
your computer.

Please refer to the x.factory Librarian Registration Page for details on how to register fc.factory.
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Running fc.factory
Starting up fc.factory is as simple as starting any application, simple double click on the icon and you're away.

During start-up, a "Splash Screen" is shown. This stays visible until a few seconds after the program has
loaded and is ready for use, but can be dismissed at any time by clicking on the Splash Screen.

fc.factory remembers the size and position of the main window between sessions, so the main window will be
sized and positioned as you left it the last time.

PC
Simply double click on the program icon for the program either in an Explorer shell, or from the desktop if you
let the installer placed a shortcut there.

You can also select the program from the Start Menu. By default, fc.factory can be found under the x.factory
Librarians Program Group.

MAC OS X
Navigate to the Applications folder in Finder and double click the fc.factory application.

You can also create "Aliases" of the application and place them anywhere you wish, such as on the desktop

To make an alias you can choose any one of the following methods:

Click the fc.factory item you have just identified and hold down the mouse button. Then, while holding
down the Command and Option keys simultaneously, drag the item to where you want the alias to
appear then let go of the mouse button and finally release the two keys. This will create an alias at
your desired location. While dragging, the ‘ghosted’ item will display a shortcut arrow which will remain
on the aliased icon when it has been created.

• 

Hold down the Ctrl key, and then click the fc.factory item as identified previously. The context menu
will be displayed, and one of the choices will be Make Alias. Click that option, and then release the
key. The fc.factory alias will appear next to the original item and can be dragged to your location of
choice.

• 

Select the fc.factory item you identified previously by clicking it once then press Command-l
(lowercase L). The fc.factory alias will appear next to the original item and can be dragged to your
location of choice.

• 

Click the fc.factory item once to select it, and then from the File menu, select Make Alias. The
fc.factory alias will appear next to the original item and can be dragged to your location of choice.

• 

Note that if your alias does not have a small arrow in the lower left corner then you have not correctly created
an alias and have probably just dragged the application launcher to a new location. If so, drag it back to the
Application folder and start again.

Command Line
You can also startup fc.factory from a command shell (e.g. MsDOS). Simply change directory to where
fc.factory is located and type the following:

java -jar fcfactory.jar
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The fc.factory Window
The main fc.factory window looks like this

The fc.factory user interface is a Multiple Document Interface (MDI), which allows you to have more than one
file open at a time.

The interface is divided into the now familiar layout of (from top to bottom):

The Title Bar• 
The Menu Bar• 
The Tool Bar• 
The Desktop• 
The Status Bar• 
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Menu Bar
The fc.factory menu bar provides a means of selecting common operations; typically those that affect a
complete file, or those that don't fit naturally upon a context sensitive popup menu.

Keyboard Shortcuts are provided for common operations.

fc.factory also provides context sensitive popup menus, which are accessible by right clicking over data
shown in a Child Window. Naturally the contents of the popup menus varies according to the type of data over
which the menu was popped up.

Main Menu Headings

The following menu headings are available.

File Menu• 
Edit Menu• 
View Menu• 
MIDI Menu• 
Window Menu• 
Help Menu• 
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The Application Menu

The Application menu is available on OS X to provide a native look and feel for OS X users; some menu
options from the standard menus are migrated here (where OS X Users would expect them to be).

About fc.factory...

This menu provides the standard OS X application menu, with the following kronos.factory specific options
along with the standard OS X options for Services (none defined for fc.factory) and Window control.

Displays the fc.factory About Dialog, which provides some basic information about the program, such as the
version number.

Preferences ...

Opens the fc.factory Preferences Dialog.

Quit fc.factory

Exits the fc.factory application.

If any files have been modified and have not been saved, you will be given the option of saving them.
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The File Menu

The File menu provides the following options (OS X and Windows versions are shown):

New ...

Creates a new file.

Open ...

Shows the Open File Dialog, which allows you to open a specified file.

Save

Saves a file using its current name.

If the file in question is a newly created file, then the Save File Dialog is brought up to allow a name to be
entered.

This option is only enabled if your copy of fs.factory is registered.

Save As ...

Saves the selected file after a name has been entered in the Save File Dialog.

This option is only enabled if your copy of fs.factory is registered.

Save All

Saves all open files that have been modified using their current names.

This option is only enabled if your copy of fs.factory is registered.

Open Workspace ...

This option allows you to select a previously saved Workspace, which is a Collection of open windows, and
the size and positions within the main fs.factory window.

When you select this option, a dialog opens which allows you to select an fs.factory workspace file (EXW).

Save Workspace ...

This option allows you to save the current size and position of the main fs.factory window, and the
arrangement of the open windows within fs.factory to a Workspace file.

This option is only enabled if your copy of fs.factory is registered.
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Export to

This option brings up the following sub menu:

These options allow you to Export the data in the currently selected file to a variety of different formats.

This option is only enabled if your copy of fs.factory is registered.

Exit

This menu option is not available if the host operating system is OS X. On OSX there is a Quit menu option in
the  fc.factory Application Menu.

If any files have been modified and have not been saved, you will be given the option of saving them.
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The Edit Menu

The Edit menu provides the following options:

Undo

Undos the previous edit stored in the Undo Buffer.

Redo

Redos the next edit stored in the Undo Buffer.

Clear Undo Buffer

Clears the Undo Buffer.

Cut

Places a copy of the selected Object(s) onto the Clipboard and deletes the selected Object(s) from the file.

Copy

Places a copy of the selected Object(s) onto the Clipboard.

Paste

Copies the Object(s) on the Clipboard into the highlighted location within the current file.

Find ...

fs.factory supports the ability to find Objects either by name or by category.

Searches start from the currently selected Object.

Selecting the Find ... option brings up the Find dialog, that allows you to specify the string to search for, along
with options that can be used to refine the search.

Find Next

If you have defined the Find criteria within the Find dialog, then this option will repeat the search using the
same criteria.

Goto ...

Selecting this option brings up the Goto Dialog, which allows you to quickly navigate to a numbered Object.
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The View Menu

The View menu provides the following options upon OSX:

Note how some of the options change depending on whether or not the Child Window is split.

The View menu provides the following options upon PC:

Note how some of the options change depending on whether or not the Child Window is split.

When the Child Window is split the Left/Top Pane and Right/Bottom Pane menu options have the following
sub menu.

Tool Bar

When checked the fc.factory Tool Bar is visible.

Status Bar

When checked the fc.factory Status Bar is visible.

No Split

When checked the current Child Window is not split.

Horizontal Split

When checked the current Child Window is split horizontally.

Vertical Split

When checked the current Child Window is split vertically.

Tree

When checked the main/left/top pane in a Child Window displays data in a Tree View.

Table

When checked the main/right/bottom pane in a Child Window displays data in a Table View.

Refresh

Refreshes all open Child Windows.

This command is provided in case the screen is not properly updated following an edit operation. There are a
couple of odd bugs I cannot track down on screen updates. So if you come across them as well, then this
command will force a redraw of the windows.
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Preferences ...

This menu option is not available if the host operating system is OS X. On OSX there is a Preferences...
menu option in the  fc.factory Application Menu.

Opens the fc.factory Preferences Dialog.
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The MIDI Menu

The MIDI menu provides the following options:

Import From MIDI

Imports Voices and Performances from the FC300 via MIDI to the currently selected Window.

Export to MIDI

Exports Voices and Performances to the FC300 via MIDI from the currently selected Window.

Note: The Export To MIDI option is only enabled if you have registered fc.factory.

MIDI Preferences ...

Opens the Preferences Dialog with the MIDI Preferences Tab active.
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The Tools Menu

The Tools menu provides the following options:

Master Patch List ...

Opens the Master Patch List dialog.

This option is only enabled if your copy of fs.factory is registered.

Library Information ...

Opens the Library Statistics dialog.

This option is only enabled if your copy of fs.factory is registered.

Batch Import to Library ...

Opens the Batch Import To Library dialog.

This option is only enabled if your copy of fs.factory is registered.

Batch Import DX7 Patches ...

Opens the Batch Import DX7 Patches Wizard.

This option is only enabled if your copy of fs.factory is registered.
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The Window Menu

The Window menu provides the following options:

In the example given above, you'll see that after the predefined menu options there are menu options that
allow you to select the windows currently open within fs.factory FC300 Controller, fcFactoru_5.syx and
180619 - PATCH.syx in our example menu).

Tile Horizontal

Arranges all non-minimised Child Windows along the horizontal axis.

Tile Vertical

Arranges all non-minimised Child Windows along the vertical axis.

Maximise Windows

Maximises all Child Windows so they all occupy the size defined by the desktop.

Restore Windows

Restores all maximised/minimised Child Windows to their normal state.

Minimise Windows

Reduces all Child Windows to their iconised state.

View FC300 Controller Data

Opens or closes the FC300 Controller Window which provides a view on the FC300 Controller data.
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The Help Menu

The Help menu provides the following options (OS X and Windows versions are shown):

Search

OS X only. This is a standard OS X Menu function currently not working with fc.factory. One day....

Get Help on fc.factory ...

Displays the fc.factory Online Help system.

View Tips and Tricks for fc.factory ...

Displays the fc.factory Tips and Tricks Dialog.

View PDF Documentation for fc.factory ...

Displays the PDF documentation for fc.factory. Note that there needs to be a registered viewer for PDF files
on your system for this command to work

View License Agreement for fc.factory ...

Displays the fc.factory License Agreement in a dialog box.

View License Agreement for fc.factory ...

Provides a link to the x.Librarian's Support Page.

About fc.factory ...

This menu option is not available if the host operating system is OS X. On OSX there is an About fc.factory
menu option in the  fc.factory Application Menu.

Displays the fc.factory About Dialog, which provides some basic information about the program, such as the
version number.

Register and Activate fc.factory ...

Displays the fc.factory registration and activation Dialog.

See the Registration Section for details of how to register fc.factory.
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Tool Bar
The Tool Bar contains buttons for common operations, such as opening and saving files.

   Creates a new file
   Displays the Open File Dialog to allow you to select a file to open

Saves the currently selected file
   Displays the Save As Dialog to allow you to select a different name for the currently selected file

Saves all the open files to disk
   Cuts the selected Objects and places them on the Clipboard
   Copies the selected Objects and places them on the Clipboard
   Pastes the contents of the Clipboard to the current selection

Undos the previous edit
Redos the previous edit

   Displays the Find Dialog to allow you to define the search criteria and then search for the first occurrence
   Searches for the next occurrence of the search criteria defined in the Find Dialog
   Imports Voices/Performances from the FC300 via the MIDI interface
   Exports Voices/Performances to the FC300 via the MIDI interface
   Displays the Preferences dialog where you can configure fc.factory
   Displays the fc.factory Online Help index page
   Enables Context Sensitive Help
   Displays the Tips and Tricks Dialog
   Displays the About Dialog

The Save and MIDI export buttons are only enabled if fc.factory is Registered.

The Tool Bar can be dragged and made a floating toolbar by clicking and dragging the handle to the left of the
Tool Bar.

The Tool Bar can also be dragged to a different window border other than the top border.

The Tool Bar can be hidden/unhidden by the Tool Bar menu option on the View menu.

The Tool Bar whilst floating can be docked once more by closing it.
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Desktop
The Desktop portion of the window is where the FC300 data is portrayed. Several files may be opened and
shown within Child Windows upon the Desktop portion of the window. The following example shows
three Child Windows open on the Desktop.

The Window Menu provides menu options to:

Tile (either vertically or horizontally) all Child Windows that are not iconised• 
Minimise all Child Windows• 
Maximise all Child Windows• 
Restore all Child Windows• 
Select a specific Child Window• 
Open the FC300 Controller Window• 

When a file is opened, a Child Window is added to the Desktop Area.
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Child Window
The Child Window provides the View upon the data within the file it is associated with.

The Child Window is maximised by default when it is opened, and can be minimised, restored or closed by the
buttons to the right of the Child Window's title bar.

The menu options on the View menu can be used to change the View to a Table view, which can show either
a Voice Table or a Performance table.

It's also possible to have either a horizontally or a vertically split View which can show any of the following
combinations:

A Tree and a Table• 
A Table and a Tree• 
Two Trees• 
Two Tables• 

The default Child Window View applied when a file is opened is set in the Default View Tab of the Preferences
Dialog.

The following example shows a Child Window that is split and showing both a Tree View and a Table View on
the same data.

The Tree and Table views support drag move and drag copy operations, and the views will automatically
scroll whilst drag operations are in progress.

fc.factory also provides one special Child Window for showing data in the FC300 Controller Window.
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Tree View

The Tree View shows the FC300 data as a hierarchical tree, and can show more information than the Table
View. The following example shows a split Child Window with two Tree Views.

Basically, information is shown as a set of hierarchical Objects. Objects may have children attached to them,
and they themselves may have further child Objects (e.g. a Patch Object, has a child Object for Patch On and
Patch Off MIDI data, expression pedals, control pedals, etc.).

The basic tree structure is a Root Object at the top of the tree under which are various Object Collections
which themselves contain further data.

You can double click on an item, and if the item is a patch, it will be exported to the controller's Edit buffer

The Tree View allows multiple Objects to be selected, which is useful for performing operations only upon
certain Objects. You can only perform operations upon Objects of the same type.

If you wish to perform an operation upon all Objects in a Collection, simply select the Collection containing the
Objects.
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Table View

The Table View provides a more high level overview of the data than the Tree View, and the representation of
the data is more compact. The following example shows a Child Window with a single Table View providing
information on a file's Patches.

The Table View can only show one Collection of Objects at a time.

Currently the Table View can show Patches in SYSEX files.

Each row within the table shows one Object.

You can double click on a row, and if the item is a voice, it will be exported to the controller's Edit buffer

The Table View's context sensitive popup menus support editing operations. The cells in a Row that contain
the Object's Category and Name can be directly edited by clicking in them.
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FC300 Controller Window

The FC300 Controller Data Window is made visible by ensuring the View FC300 Controller Data option in
the Window Menu is checked.

This Child Window is a special View that shows the FC300 data directly. You can import data into it without
creating a new file and you can rearrange the data within it and have that reflected in the FC300.
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Status Bar

The Status Bar provides the following pieces of information (from left to right) for the Child Window which is
currently selected:

The name of the file currently open, if any. If no file has been selected then this field is blank• 
The type of the file• 
Whether or not the file has been modified• 
If the left/top split pane is a table this indicator identifies what the table is showing.• 
If the right/bottom split pane is a table this indicator identifies what the table is showing.• 

The Status Bar can be hidden/unhidden by the Status Bar menu option on the View menu
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Program Features
fc.factory provides the following features:

File Operations• 
Undo/Redo Support• 
Clipboard Support• 
MIDI Support• 
Find and Goto Support• 
Editing Features• 
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File Operations
fc.factory supports the following file operations:

Create New Files• 
Open Existing Files• 
Save Files• 
Open and Save Workspaces• 
Export Data• 
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Create New File

When the New File ... option from the File Menu or the  button on the Toolbar is selected, a new file is
created.

The new data file is given a name in the form of "fcFactory_n", where n is a number that increments every
time a file is created.

Note, this is different from initialising data in a file, as a totally new file is created.
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Open Existing File

When the Open ... option from the File menu or the  button on the Toolbar is selected the following dialog
will appear, allowing a file to be selected.

fc.factory checks to ensure that the selected file is a valid FC300 format file, and an error dialog will appear if
the file is not valid.

If a file selected for opening is already open, fc.factory will ask if you want to replace the file that is in memory.
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Save Open Files

When you save a file to disk using: the Save As ... command from the File Menu, or when a file created using
the New ... command from the File Menu is saved for the first time, the following dialog appears to allow you
to select a name for the file

You can save a file to a different type by selecting Files of Type to be the new file type.
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Workspaces

fc.factory allows you to save the current size and position of the main fc.factory window, and the arrangement
of the open Child Windows within fc.factory to a file known as a Workspace.

This allows you to save a Workspace you are using for future recall at a later date.

The following for each Child Window remembered:

Window size, position and status (normal, maximised or minimised)• 
Horizontal/Vertical Splits, including split position• 
Pane type(s) (e.g. Tree, Patch Table etc.)• 
Tree node expansion status• 
Table column widths• 
Scroll position of the pane(s)• 
Selection state of the tree nodes, or table rows• 
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Export Data

fc.factory allows you to export the data in the currently selected file to a variety of different formats.

HTML• 
XML• 
SpreadSheetML• 

HTML ...

This option allows you to export a listing of the data in HTML format.

XML ...

This option allows you to export a listing of the data in XML format.

This export option is intended to provide a means of importing FC300 data into other programmes, e.g. a
database

 SpreadSheetML ...

This option allows you to export a listing of the data in Microsoft SpreadSheetML format.

This export option is intended to provide a means of importing FC300 data into either Microsoft Word or Excel,
which is a great way to start documenting your patch collections.
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Undo Buffer
fc.factory supports a multi-level Undo/Redo Buffer facility on all edits.

The number of edits which are stored is 100.

The Undo/Redo commands can be found both within the Edit Menu, and on the Toolbar.

Please note that the undo buffer is global across all open files, and is cleared when any file is closed. This
may be improved in later releases.

The undo buffer can be cleared by the selecting the Clear Undo Buffer option on the Edit Menu. The
intention of this feature is to help cope with low memory situations, as it will free up the memory used by
stored edits.
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Clipboard Support
The fc.factory clipboard works just like the clipboard in other applications. It allows you to place an Object or a
copy of an Object upon the clipboard and then paste that Object elsewhere within a file or another file.

You can Cut/Copy either a single Object or a Collection of Objects onto the clipboard.

You can only paste from the clipboard to the current location in a file if it makes sense to do so. For example:

You cannot paste a Patch onto an Expression Pedal• 
You cannot paste ten Patches at the end of a Patch Collection if the selection is at Patch 90 or higher• 

The fc.factory clipboard is "local" to the application, and only fc.factory Objects can be placed upon it.

fc.factory does not support the system clipboard so it is not possible to cut and paste between fc.factory and
other applications. I don't think this is a major drawback because I cannot think of any circumstances where
you would wish to do this!
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MIDI Support
To use fc.factory MIDI Export support, your copy of fc.factory needs to be registered.

Configuring MIDI Support

To configure MIDI support, go to the MIDI Preferences tab in the Preferences Dialog, and set up the following:

Input MIDI Port and Output MIDI Port should be set to the MIDI port(s) to which the FC300 is
connected

• 

SYSEX Device Number should match the FC300 Device Number setting • 

If the Device Number on the FC300 is set to  ALL then it will accept data for any SYSEX Device.

You can check that these settings work by pressing the Test FC300 MIDI Settings button. When you press
this button a test message is sent to the FC300 and if the test is successful, the following dialog is shown.

If the test was not successful then the following dialog is shown.

The above steps set up the basic communication mechanism for MIDI support, and you then can set up the
remaining options according to your preferences:

If you wish for fc.factory to always read the FC300 Voice/Performances on startup then check the
Read FC300 MIDI Data on Startup checkbox

• 

If you wish for changes made to the FC300 Controller Window to be automatically written to the
FC300 then check the Automatically Update FC300 after Controller Window Edit checkbox

• 

You can adjust how long that fc.factory will wait for a response from the FC300 by adjusting the
Timeout Delay value, which is given in milliseconds

• 

The Transmit Buffer Size, Transmit Delay Between Buffers and Transmit Delay Between Objects values
should not require adjustment. fc.factory sends data to the FC300 by dividing the data into packets the size of
which are specified by the Transmit Buffer Size value.

When fc.factory sends a packet it waits for the time period specified by Transmit Delay Between Buffers
before sending the next packet, and it waits for the time period specified by Transmit Delay Between
Objects after the last packet is sent. The delay parameters are specified in milliseconds.

You may need to adjust these values (smaller buffers, longer delays) if communications is not reliable, and
you may if you wish adjust these values (larger buffers, smaller delays) to maximise data transfer
performance. If you adjust these values, please ensure that you test the transfer to ensure it is reliable,
otherwise you may risk losing data.

Note: Some MIDI interfaces do not like large packet sizes.

Importing FC300 Data from FC300 Memory

Please note that there is no MIDI SYSYEX commands that allow Patches to be requested from the FC300.
Therefore the fc.factory MIDI import function requires that you initiate a manual BULK DUMP from the FC300.
The FC300 does not support the export of individual patches.

You can get all the FC300 Patches into any Child Window (including the FC300 Controller Window) by
selecting the Import from MIDI option on the MIDI Menu, or the      button on the Tool Bar.

When you select this option, the following dialog is shown.
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fc.factory is now waiting for you to initiate the BULK DUMP from the FC300. If required you can press the
CANCEL button to cancel the dump.

to initiate the BULK DUMP, follow the instructions on Page 53/54 of the FC300 Manual.

As fc.factory currently only supports Patch Mode, select PATCH from the list of data items to send before
pressing the FC300 WRITE button. This is not strictly necessary as fc.factory will ignore all the other data, but
if the FC300 is sending all data then the transfer will take longer.

Once data is being transmitted by the FC300, fc.factory will show the progress in the dialog box as shown
below. Whilst the FC300 will transmit all data until it is finished, if you wish you can cancel the download in
fc.factory.

Once all data has been transmitted, press the OK button to import the data into the current file (or Controller
window) or press the CANCEL button to cancel the import.

Note if you import MIDI data into a Child Window which is opened from a data file, then the FC300 Controller
Window is also updated with the Data being imported.

Exporting FC300 Data to FC300 Memory

You can export all FC300 data using the Export MIDI option on the MIDI Menu, or the      button on the Tool
Bar.

You can also export a single Patch or a selection of Patches to the FC300 by selecting the required Patches
and selecting the export to FC300 Memory option from the Patch's Context Sensitive Menu. You can also use
the keyboard shortcuts for doing this.

The patches are written to the corresponding FC300 memory locations.

Note if you export MIDI data to a Child Window which is opened from a data file, then the FC300 Controller
Window is also updated with the Data being exported.

Importing/Exporting FC300 Data from/to the FC300 Edit Buffer

You can also import/export a Patch to/from the FC300 Edit Buffer (Temporary Area) by selecting a single
Patch and selecting the import/export to/from FC300 Edit Buffer options from the Patch's Context Sensitive
Menu. You can also use the keyboard shortcuts for doing this.

Copying/Moving Patches

And you can also move/copy Patches between the FC300 Controller Window and Child Windows using drag
and drop.

Finally you can also perform all the operations on Patches in the FC300 Controller Window that you can upon
Patches in a normal Child Window.

If you have the Automatically Update FC300 after Controller Window Edit option active, when you change
data the FC300 Controller Window then the changes are automatically exported to the FC300.

So you may wish to turn the Automatically Update FC300 after Controller Window Edit option off during
intensive editing sessions. Once you've made all your changes you then select the Export MIDI option on
the MIDI Menu, or the      button on the Tool Bar Export option to manually export the changes.

If you quit fc.factory with changes still present in the FC300 Controller Window that have not been exported,
then you will be asked if you wish to export the data or not.
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Find and Goto Facilities
Find Dialog

fc.factory supports the ability to find Objects by name.

Searches start from the currently selected Object.

Selecting the Find ... option on the Edit Menu brings up the Find dialog, that allows you to specify the string to
search for. In addition, there are several options that can be selected to help refine the search.

Find What The text string to search for.
Match Case If this option is checked then the search is case sensitive. If this option is not checked then

the search is case insensitive.
Match Whole
Name

If this option is checked then the search string must match the entire name of an Object.
E.g. "pan" would match a Voice called "pan", but not a Voice called "pandora". If this option
is not checked then the search can match a sub string within a name. E.g. "dor" would
match a Voice named "dor" and a Voice called "pandora".

Use Wild Cards If checked fc.factory will treat the "Find What" text as a "regular expression" to allow you
more control over the search, such as matching text at the start of a name, or the end of a
name, words with numbers in, etc.

The regular expression language used for fc.factory wild card support is the Perl Regular Expression Syntax.
Rather than try and write up this powerful syntax myself into the fc.factory documents, I'll direct you to the Perl
Regular Expression Syntax page for a description of how to use this powerful feature.

Goto Dialog

Selecting this option on the on the Edit Menu brings up the Goto Dialog

Item Type The type of Object to go to. Currently only Patches are supported.
Item Number The number of the Object to go to.
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Editing Features
fc.factory supports the following editing features:

General Editing Features• 
Controller Editing Features• 
Patch Editing Features• 
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General Editing Features

fs.factory supports many editing features, some of which are classed as general features that are applicable
to all or most Objects.

The general features are described here in one place for convenience:

Copy/Move Object• 
Initialise Object• 
Rename Object• 
Insert Object• 
Delete Object• 
Sort Objects• 

The following table shows whether or not a general edit operation can be applied to a particular type of
Object:

Object Type Move Copy Initialise Rename Insert Delete Sort
Controller Object Y Y Y N N N N
Patch Collection Y Y Y N N N Y
Patch Y Y Y Y Y Y N
Patch Selected MIDI
Strings

Y Y Y N N N N

Patch Unselected MIDI
Strings

Y Y Y N N N N

Patch
Selected/Unselected
MIDI Strings

Y Y Y N Y Y N

Expression Pedals Y Y Y N N N N
Expression Pedal Y Y Y N Y Y N
Expression Pedal
Switch

Y Y Y N N N N

Control Pedals Y Y Y N N N N
Control Pedal Y Y Y N Y Y N
Control Pedal On
Messages

Y Y Y N N N N

Control Pedal Off
Messages

Y Y Y N N N N

Control Pedal ON/OFF
MIDI Strings

Y Y Y N Y Y N
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Copy/Move Object

fc.factory makes extensive use of drag and drop for copying and moving Objects.

You can drag copy or move Objects within a file or between files, and you can drag single items or multiple
items.

The default drag operation is to move an Object, and there are two types of move operations:

Moving an Object within its Parent Collection (e.g. moving a Patch from location 1 to location 4)• 
Moving an Object to a new Parent Collection (e.g. moving a Patch from one file to another file)• 

When you move an Object to a new Parent Collection then the original Object is removed and replaced with
an initialised Object of the same type.

To copy an Object using drag and drop, you must have the DRAG MODIFIER key held down during the
operation. The DRAG MODIFIER key is platform dependent. On the PC platform it is the CTRL key.

You can tell that a copy operation is in progress as the drag image icon has a + sign visible.

When you drag multiple items they must be of the same type. For example you can drag several Patches, but
not Expression Pedals and Control Pedals together.

fc.factory provides the following drag/drop feedback to assist in determining the effects of a drag/drop
operation:

Cursor: Indicates if the move is either a copy or a move, or if the drop is invalid (e.g. trying to drag a
Control Pedal onto an Patch On MIDI String)

• 

Drag image: A simple pictorial representation of what is being dragged• 
Drop Point: fc.factory shows the drop point as either a cue line drawn between Objects if an Object is
being moved within its parent (e.g. an Control Pedal within a Control Pedal collection), or a cue
rectangle drawn around the drop location for all other moves and copy operations which are valid

• 

When a Child Window is split, Objects can be dragged and dropped between either side of the split point. This
is handy, for example, for dragging Objects between the start of a Collection and the end of a Collection.

The Tree and Table views will auto-scroll in drag and drop operations, when you move the cursor to either the
top or the bottom of the pane and hold it there.

If you drag an Object onto a Tree View and over a valid parent Object (e.g. an Patch over a Patch Collection)
and the parent Object is collapsed within the Tree, and you hold the cursor over the Parent Object for a few
seconds it will automatically expand.

Initialise Object

Initialises the selected Object to its default state.

Multiple Objects of the same type can be selected for initialisation.

The Initialise command is found upon the Context Sensitive Menu in both the Tree View and the Table
View.

Rename Object

Renames the selected Object using the following dialog

Only one Object can be selected for renaming.

The  Rename command is found upon the Context Sensitive Menu in the Tree View

To rename Objects in the Table View, simply double click in the Name Cell of the required Object to edit the
name.

Insert Object

Inserts an Object into a Collection at the current location.
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The Insert command is found upon the Context Sensitive Menu in both the Tree View and the Table View.

You can insert more than one Object at a time by selecting multiple Objects prior to executing the Insert
command.

For example if you wish to insert three Patches at location 10, select Performances 10, 11 and 12 and then
execute the Insert command.

Note that when you insert one or more Objects, then the commensurate number of Objects at the end of the
Parent Collection are removed if required. This is necessary to maintain the correct number of Objects in a
Collection.

For example, an FC300 Patch Collection can only contain 100 Voices, so if two Patches are inserted into the
Collection then two Patches must be removed from the end of the Collection to maintain the correct size.

Delete Object

Deletes an Object at the current location.

The Delete command is found upon the Context Sensitive Menu in both the Tree View and the Table View.

You can delete more than one Object at a time by selecting multiple Objects prior to executing the Delete
command.

For example if you wish to delete three Patches at location 10, select Patches 10, 11 and 12 and then execute
the Delete command.

Note that when you delete one or more Objects, then a commensurate number of Objects at the end of the
Parent Collection are added if required. This is necessary to maintain the correct number of Objects in a
Collection.

For example, an FC300 Patch Collection must contain 100 Patches, so if two Patches are deleted from the
Collection then two Patches must be added to the end of the Collection to maintain the correct size.

Sort Objects

The  Sort by Name command is found upon the Context Sensitive Menu in both the Tree View and
the Table View.

In the Tree View the sort option is accessed via the Context Sensitive Menu for the Collection that you wish
to sort (e.g. the Patch Collection to sort Patches).

In the Table View the sort option is accessed via the Context Sensitive Menu for any Object. The sort can
also be initiated by clicking in the Name >column header.
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Controller Editing Features

fc.factory supports the following editing operations upon the Controller Object within the Tree View of a Child
Window:

Move• 
Copy• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access these features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Controller Object to activate the Controller Object's Context Sensitive Menu.

The Controller Object is only shown within a Tree View and is the first Object in the Tree View. It is called:

SYSEX File
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Patch Editing Features

fc.factory supports the following editing operations upon the Patch Collection shown within the Tree View of
a Child Window:

Copy/Move• 
Initialise• 
Sort by Name• 
Import Data From FC300• 
Export Data to FC300 (only available if fc.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

The Patch Collection Object in file is only shown within a Tree View and is called User Patches.

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Collection to activate the Patch Collection's Context Sensitive Menu.

fc.factory supports the following editing operations upon the Patch Objects within the Tree View or Table
View of a Child Window:

Copy/Move• 
Initialise• 
Rename• 
Insert• 
Delete• 
Export to FC300 (only if available fc.factory is registered)• 
Import from FC300 Edit Buffer• 
Export to FC300 Edit Buffer (only if available fc.factory is registered)• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
or selection of Patches to activate the Patch's Context Sensitive Menu.

You can also directly edit the following Patch data Patch Operators

Patch Selected MIDI Strings• 

Patch Unselected MIDI Strings• 

Expression Pedals• 

Control Pedals• 

Export to FC300 Memory

Exports Patches from the currently selected Child Window to the FC300 Memory locations.

You can export:

A Single Patch• 
A Selection of Patches• 
All Patches by selecting the Patch Collection• 

Import from FC300 Edit Buffer

Imports the Patch currently in the FC300 Patch Edit Buffer into the Patch currently selected within the
active Child Window.

Note if you have more than one Patch selected then this operation is not available

Export to FC300 Edit Buffer

Exports the Patch currently selected within the active Child Window to the FC300 Patch Edit Buffer.

Note if you have more than one Patch selected then this operation is not available

Patch Selected Messages Editing Features

fc.factory supports the following editing operations upon the Patch Selected Messages Collection shown
within the Tree View of a Child Window:
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Copy/Move• 
Initialise• 
Add Patch Messages• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Selected Messages Collection to activate the Patch Selected Messages Collection's Context
Sensitive Menu.

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Message or selection of Patch Messages to activate the Patch Message's Context Sensitive Menu.

You can also drag and drop a Patch Selected Message Collection onto the following Objects

A Patch Unselected Messages Collection.• 
A Patch Control Pedal On Messages Collection.• 
A Patch Control Pedal Off Messages Collection.• 

Add Patch Messages

Adds Patch Messages to a Patch Selected Message Collection.

You can add more than one Patch Message at a time if you wish by holding down the ALT key when you
select the Add Patch Message option from the Context Sensitive Menu. Holding down the ALT key will bring
up the following Dialog Box which allows you to specify the number of Patch Messages to add:

fc.factory supports the following editing operations upon the Patch Messages Objects within the Tree View
of a Child Window:

Copy/Move• 
Initialise• 
Insert• 
Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Message or selection of Patch Messages to activate the Patch Message's Context Sensitive Menu.

You can also drag and drop Patch Messages onto the following Objects

A Patch Selected Messages Collection (the Patch Messages will be added to the existing Patch
Messages).

• 

A Patch Unselected Messages Collection (the Patch Messages will be added to the existing Patch
Messages).

• 

A Patch Control Pedal On Messages Collection (the Patch Messages will be converted to Control
Pedal Messages and added to the existing Control Pedal Messages).

• 

A Patch Control Pedal Off Messages Collection (the Patch Messages will be converted to Control
Pedal Messages and added to the existing Control Pedal Messages).

• 

A Control Pedal Message (the Patch Messages will be converted to a Control Pedal Message).• 

Patch Unselected Messages Editing Features

fc.factory supports the following editing operations upon the Patch Unselected Messages Collection shown
within the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Add Patch Messages• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 
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To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Unselected Messages Collection to activate the Patch Unselected Messages Collection's Context
Sensitive Menu.

You can also drag and drop a Patch Unselected Message Collection onto the following Objects

A Patch Selected Messages Collection.• 
A Patch Control Pedal On Messages Collection.• 
A Patch Control Pedal Off Messages Collection.• 

Add Patch Messages

Adds Patch Messages to a Patch Unselected Message Collection.

You can add more than one Patch Message at a time if you wish by holding down the ALT key when you
select the Add Patch Message option from the Context Sensitive Menu. Holding down the ALT key will bring
up the following Dialog Box which allows you to specify the number of Patch Messages to add:

fc.factory supports the following editing operations upon the Patch Messages Objects within the Tree View
of a Child Window:

Copy/Move• 
Initialise• 
Insert• 
Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Message or selection of Patch Messages to activate the Patch Message's Context Sensitive Menu.

You can also drag and drop Patch Messages onto the following Objects

A Patch Selected Messages Collection (the Patch Messages will be added to the existing Patch
Messages).

• 

A Patch Unselected Messages Collection (the Patch Messages will be added to the existing Patch
Messages).

• 

A Patch Control Pedal On Messages Collection (the Patch Messages will be converted to Control
Pedal Messages and added to the existing Control Pedal Messages).

• 

A Patch Control Pedal Off Messages Collection (the Patch Messages will be converted to Control
Pedal Messages and added to the existing Control Pedal Messages).

• 

A Control Pedal Message (the Patch Messages will be converted to a Control Pedal Message).• 

Patch Expression Pedals Editing Features

fc.factory supports the following editing operations upon the Patch Expression Pedals Collection shown
within the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Expression Pedals Collection to activate the Patch Expression Pedals Collection's Context
Sensitive Menu.

fc.factory supports the following editing operations upon the Expression Pedal Objects within the Tree View
of a Child Window:

Copy/Move• 
Initialise• 
Insert• 
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Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Expression Pedal or selection of Patch Expression Pedal to activate the Patch Expression Pedal's
Context Sensitive Menu.

fc.factory supports the following editing operations upon the Patch Expression Pedal Switch Objects within
the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Expression Pedal Switch to activate the Patch Expression Pedal Switch's Context Sensitive Menu.

Patch Control Pedals Editing Features

fc.factory supports the following editing operations upon the Patch Control Pedals Collection shown within
the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over the
Patch Control Pedals Collection to activate the Patch Control Pedals Collection's Context Sensitive
Menu.

fc.factory supports the following editing operations upon the Control Pedal Objects within the Tree View of
a Child Window:

Copy/Move• 
Initialise• 
Insert• 
Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Control Pedal or selection of Patch Control Pedal to activate the Patch Control Pedal's Context Sensitive
Menu.

fc.factory supports the following editing operations upon the Patch Control Pedal On Messages Collection
or the Patch Control Pedal Off Messages Collection within the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Add Control Pedal Messages• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a Patch
Control Pedal On/Off Messages Collection to activate the Patch Control Pedal On/Off Messages's
Context Sensitive Menu.

You can also drag and drop a Patch Control Pedal On Messages Collection onto the following Objects

A Patch Selected Messages Collection.• 
A Patch Unselected Messages Collection.• 
A Patch Control Pedal Off Messages Collection.• 

You can also drag and drop a Patch Control Pedal Off Messages Collection onto the following Objects

A Patch Selected Messages Collection.• 
A Patch Unselected Messages Collection.• 
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A Patch Control Pedal On Messages Collection.• 

Add Control Pedal Messages

Adds Control Pedal Messages to a Patch Control Pedal Message On/Off Collection.

You can add more than one Control Pedal Message at a time if you wish by holding down the ALT key when
you select the Add Control Pedal Message option from the Context Sensitive Menu. Holding down the ALT
key will bring up the following Dialog Box which allows you to specify the number of Control Pedal Messages
to add:

fc.factory supports the following editing operations upon the Control Pedal Messages Objects within
the Tree View of a Child Window:

Copy/Move• 
Initialise• 
Insert• 
Delete• 
Cut to Clipboard• 
Copy to Clipboard• 
Paste from Clipboard• 

To access all features other than Move and Copy (which you do via "Drag and Drop"), right click over a
Control Pedal Message or selection of Control Pedal Messages to activate the Control Pedal Message's
Context Sensitive Menu.

You can also drag and drop Control Pedal Messages onto the following Objects

A Patch Selected Messages Collection (the Control Pedal Messages will be converted to Patch
Messages and added to the existing Patch Messages).

• 

A Patch Unselected Messages Collection (the Control Pedal Messages will be converted to Patch
Messages and added to the existing Patch Messages).

• 

A Patch Control Pedal On Messages Collection (the Control Pedal Messages will be added to the
existing Control Pedal Messages).

• 

A Patch Control Pedal Off Messages Collection (the Control Pedal Messages will be added to the
existing Control Pedal Messages).

• 

A Patch Message (the Control Pedal Messages will be converted to a Patch Message).• 
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Preferences
The fc.factory preferences are accessed via the View menu Preferences ... option, or the  button on
the Toolbar.

Selecting this option opens a Tabbed dialog with the following tabs which group related parameters:

Check Preferences• 
Default View Preferences• 
MIDI Preferences• 
EXP/CTL Preferences• 
Miscellaneous Preferences• 

To view and modify a set of parameters, click on the relevant tab.
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Check Preferences
The Check Preferences tab is shown below:

This tab has the following options:

Check For Duplicates When
Moving or Copying Objects

If you move or copy an Object to a destination file and the Object already
exists then a warning is presented giving you the option to continue or
cancel the operation.

Ignore File Checksum Errors If you select this option, then any detected checksum errors in the
SYSEX data is ignored.
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Default View Preferences
The Default View Preferences tab is shown below:

Default View Defines the type of view that is applied to a Child Window when it is first
opened.

The following options are available:

No Split• 
Horizontal Split• 
Vertical Split• 

Pane/Left Pane/Top Pane Defines the type of view shown in the single pane of an unsplit view, the
left pane of a horizontally split view or the top pane of a vertically split
view.

The following options are available:

Tree View• 
Table View• 

Right Pane/Bottom Pane This control is only visible if the Default View option is set to either
Horizontal Split or Vertical Split.

Defines the type of view shown in the right pane of a horizontally split
view or the bottom pane of a vertically split view.

The following options are available:

Tree View• 
Table View• 

View Tool Bar Controls if the toolbar is visible at startup.
View Status Bar Controls if the status bar is visible at startup.
View Backdrop In Child Window This option controls if the image backdrop is displayed in Child Windows.

You may wish to turn off this option if you find the scrolling of the Child
Window is slow on your machine.

MIDI Preferences
The MIDI Preferences tab is shown below:
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This tab has the following options:

Keyboard Input MIDI
Port

Sets the port used for accepting MIDI data from a keyboard and routing it to the
output MIDI port using the MIDI Router Dialog.

Input MIDI Port Sets the port used for MIDI input from the available ports.
Output MIDI Port Sets the port used for MIDI output from the available ports.
SYSEX Device Number Sets the SYSEX device number used for SYSEX transfers. This must match the

Device No value set in the FC300's UTILITY mode. If the FC300 Device No is set
to all then it will receive all FC300 SYSEX messages irrespective of the device
number in the message.

Timeout Delay Sets the time that fc.factory waits for a response from the FC300 before timing out
and reporting an error. The value is specified in milliseconds.

Transmit Buffer Size Sets the size of the transmit buffer used for sending data to the FC300. Some
MIDI interfaces don't like data coming in big chunks and you may need to set this
to get a reliable transfer of data. The value is specified in milliseconds.

Transmit Delay Between
Buffers

This sets the delay that fc.factory waits for between sending buffer sized data
packets. The value is specified in milliseconds.

Transmit Delay Between
Objects

This sets the delay that fc.factory waits for after sending a complete object. The
value is specified in milliseconds.

Automatically Update
FC300 after Synth
Window Edit

When this option is checked, if the FC300 Synthesizer Window is edited then the
edited data will be automatically sent to the FC300.

Test FC300 MIDI
Settings

Tests to see if MIDI communications is working using the specified values.

The Transmit Buffer Size, Transmit Delay Between Buffers and Transmit Delay Between Objects values
should not require adjustment. fc.factory sends data to the FC300 by dividing the data into packets the size of
which are specified by the Transmit Buffer Size value.

When fc.factory sends a packet it waits for the time period specified by Transmit Delay Between Buffers
before sending the next packet, and it waits for the time period specified by Transmit Delay Between
Objects after the last packet is sent. The delay parameters are specified in milliseconds.

You may need to adjust these values (smaller buffers, longer delays) if communications is not reliable, and
you may if you wish adjust these values (larger buffers, smaller delays) to maximise data transfer
performance. If you adjust these values, please ensure that you test the transfer to ensure it is reliable,
otherwise you may risk losing data.

Note: Some MIDI interfaces do not like large packet sizes.
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Miscellaneous Preferences
The Miscellaneous Preferences tab is shown below:

This tab has the following options:

Startup Directory Allows the startup directory to be specified. Note: no validation is
performed on this pathname, so please ensure it is valid. I may add
validation later.

The [...] button to the right of the field brings up a dialog that allows you
to select the directory instead of typing it in.

Load Last File On Startup Controls if the last file opened in the previous session is automatically
loaded when fc.factory is next invoked.
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EXP/CTL Preferences
The EXP/CTL Preferences tab allows you to match the pedal configuration of your FC300 as set in UTILITY
mode, and as described on Page 50 of the FC300 Manual.

If you set these settings to match your FC300 EXP/CTL pedal configuration, then the EXP/CTL data will
appear under the appropriate collection with a Patch; either the Expression Pedal Collection or the Control
Pedal Collection.

The EXP/CTL Preferences tab is shown below:

This tab has the following options:

SYS:E3/C3 Type Allows you to set whether or not the pedal mode is either Expression
Pedal 3 or Control Pedal (CTL) 3.

SYS:E4/C5 Type Allows you to set whether or not the pedal mode is either Expression
Pedal 4 or Control Pedal (CTL) 5.

SYS:E5/C7 Type Allows you to set whether or not the pedal mode is either Expression
Pedal 5 or Control Pedal (CTL) 7.

Fetch Settings from the FC300 Allows you to automatically get these settings from the FC300 if it is
connected.

Note: you can only adjust these settings if no files are open within fc.factory. This is to ensure that there is no
possibility of corrupting data if you were to change the settings, because these settings determine whether or
not MIDI data is interpreted as either Expression Pedal data or Control Pedal data when data is loaded or
saved.

If one or more files are open in fc.factory, the following message is displayed instead of the tab controls being
shown.
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Online Help
fc.factory provides a full online version of the fc.factory manual.

If you select Help ... from the Help Menu or the   button on the Tool Bar, the Help Window is opened.

The Help Window works just like a web browser window, so its operation should be quite familiar to you.

The left pane of the Help Window shows a tabbed navigation pane to allow you to quickly navigate to a topic,
whilst the right hand pane shows the help topic.

The navigation pane can show three different views, depending on which tab you select:

    Displays the Table of Contents Navigation Pane, providing a structured list of fc.factory topics• 
    Displays the Index Navigation Pane, providing an indexed list of fc.factory topics• 
    Displays the Search Navigation Pane, allowing you to search the help topics for keywords• 

The Help Window has the following Tool Bar buttons:

    Navigates backwards to the last page in the access sequence. If you press and hold the mouse
button over this button, you will get a list of accessed pages

• 

    Navigates forwards to the next page in the access sequence. If you press and hold the mouse
button over this button, you will get a list of accessed pages

• 

    Selects the home page• 
    Refreshes the current page• 
    Prints the current page• 
    Displays the print settings dialog• 
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Context Sensitive Help
You can access context sensitive help by:

pressing the your Computer Platform's Help Key ( F1 on the PC platform), which will load the help
page associated with the Component within the fc.factory Window that currently has Focus (is
responding to the keyboard and mouse).

• 

pressing the  button on the Tool Bar and the clicking over the item of interest• 

You can press the Help Key in any fc.factory Dialog to access the relevant help page for the Dialog.
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Tips and Tricks
The fc.factory tips and tricks dialog is shown below:

This dialog has the following controls:

Close Closes the Tips and Tricks Dialog
Next Tip Selects the next tip in sequence
Show Tips at
Startup

If checked then when fc.factory starts up, the Tips and Tricks Dialog is automatically
opened

List of Tips and Tricks
Just in case you want the tips and tricks shown by the dialog as one single list, here they are.

Double Clicking a patch

If you double click a patch in a file or the library, it will be sent to the controller's edit buffer. If you triple click
instead, the MIDI Router dialog will be opened after the voice is sent to the controller's edit buffer.

MIDI Support

fc.factory supports the transfer of Patches between fc.factory and the FC300 via MIDI.

(NOTE: The MIDI export features are available only to registered users).

Context Sensitive Help

If you press the Help Key ( F1 on a PC) then you can get context sensitive help, including within Dialogs.

Keyboard Shortcuts

fc.factory supports numerous keyboard shortcuts as an alternative to using the mouse.

Take a look in the online help or the fc.factory manual for details of the supported keyboard shortcuts

Table Sorting

You can sort Patch Tables by name by clicking in the Table Name Column header.

You can only DRAG COPY Certain Objects

If you are trying to perform a drag operation of a Voice onto a Performance Part and are wondering why
fc.factory is not allowing you to perform the drag, you must be holding down the CTRL key during the drag.
Holding down the CTRL key turns the operation from a Drag Move operation to a Drag Copy operation.

Sometimes during a drag operation, the only sensible operation that can be undertaken is a copy operation.

Workspaces

fc.factory allows you to save a Window arrangement as a Workspace which you can then recall at a later
date.
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The FC300 Controller Window

fc.factory has a special window called the FC300 Controller Window. This is a special window that represents
the FC300 Controller itself.

By setting up the MIDI preferences settings you can Automatically export data from the FC300 Controller
Window to the FC300 Controller when the data in the FC300 Controller Window is edited

Exporting Files to MIDI

You can export a file directly to MIDI once it is opened. If you do this, then the data being exported is also
copied to the FC300 Controller Window.

Importing from MIDI into a File

You can import directly from MIDI into a file. If you do this, then the data being imported is also copied to the
FC300 Controller Window.
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About fc.factory
The about dialog is shown when the About ... option from the Help Menu or the  button on the Tool Bar is
selected.

The dialog shows some basic information about the program including the version number and the License
status of fc.factory.

It also shows which Java Run Time Environment that fc.factory is running in.
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Glossary
Term Definition
Child Window A window associated with an FC300 data file that you have opened that is used to

display the contents of the file.

Several Child Windows can be open within the fc.factory Desktop.
Clipboard A temporary storage area used for transferring data within a Child Window or between

Child Windows.
Collection A group of similar and related Objects.

For example a Patch Collection stores the 100 Patch Objects that a file can contain
Context Sensitive
Help

The ability of the help system to tailor the help being displayed according to where the
user pressed the Help key.

Context Sensitive
Menu

The popup menu that is displayed in either the Tree View or Table View that provides a
set of commands specific to the currently selected Object

Desktop The area within the fc.factory window where Child Windows can be opened
Drag and Drop The name for the mechanism that allows a use to move data by dragging it with a mouse

and dropping it at a new location.
DRAG MODIFIER The keyboard key that is held down to turn a Drag and Drop move operation into a copy

operation.

On the PC platform, the DRAG MODIFIER key is the CTRL (control) key
FC300 Controller
Window

A special instance of a Child Window that doesn't display data in a file, but which
displays User data imported from the FC300 via MIDI

JRE Java Run-time Environment. This provides the Java environment which fc.factory needs
in order to run.

MDI Multiple Document Interface. The type of user interface used by fc.factory which allows
several Windows to be open within the main application window.

Menu Bar The area of the fc.factory Window that contains the set of menus used for accessing the
main functions provided by the application.

MIDI Musical Instrument Digital Interface. The primary means by which digital data is
exchanged in a serial form between synthesizers and computers.

Object A piece of FC300 data such as a Patch or a Patch Collection.
Regular Expression A system by which certain character sequences are interpreted not as plain text but as

commands that can provide a tailored search for occurrences of text
Status Bar The area of the fc.factory Window that is used to display status information upon the

currently selected Child Window. 
Table View A View which displays data in a file arranged in tabulated rows of data
Tool Bar The area of the fc.factory Window that contains a set of buttons to provide easy access

to commonly used commands
Tree View A View which displays data in a file arranged in a hierarchical tree structure.
View The means by which the data in a file is viewed.

A Child Window provides the view upon an FC300 File that you have opened.

The view can be either a Tree View or a Table View.

You can have several views open upon the same data, for example when you have split
a Child Window.

Workspace An arrangement of the main fc.factory Window and Child Windows which can be saved
for subsequent recall.
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Keyboard Short Cuts
fs.factory provides many keyboard shortcuts for navigation and performing editing operations.

In general, navigating between components uses these keys:

Tab. Moves keyboard focus to the next component or to the first member of the next group of
components.

• 

Ctrl-Tab. Moves keyboard focus to the next component or to the first member of a group of
components when the current component accepts a tab (as in text fields, tables, and tabbed panes).

• 

Shift-Tab. Moves keyboard focus to the previous component or to the first component in the previous
group of components.

• 

Arrow keys. Move keyboard focus within the individual components of a group of components--for
example, within menu items in a menu or within tabs in a tabbed pane.

• 

The shortcuts are divided into the following categories:

Keyboard shortcuts for the Desktop and Child Windows• 
Keyboard shortcuts for Tree Views• 
Keyboard shortcuts for Table Views• 
Keyboard shortcuts for Editing within Tree and Table Views• 
Keyboard shortcuts for the Preferences Dialog• 
Keyboard shortcuts for Text Editing Fields• 

Keyboard Shortcuts for the Desktop and Child Windows

Action Keystroke Notes

New File Ctrl-N

Open File Ctrl-O

Save File Ctrl-S

Save File As Ctrl-A

Save All Files Ctrl-L

Open Workspace Ctrl-ALT-O

Save Workspace Ctrl-ALT-S

Tile Horizontally Ctrl-H

Tile Vertically Ctrl-V

Maximise Windows Ctrl-M

Restore Windows Ctrl-R

Minimise Windows Ctrl-I

Closes Child Window Ctrl-F4

Moves Child Window Ctrl-F7

Resizes Child Window Ctrl-F8

Minimizes Child Window Ctrl-F9

Switch to next Child Window on the
Desktop

Ctrl-F6
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Keyboard Shortcuts for Tree Views

Action Keystroke Notes

Expands current Object Right arrow

Collapses current Object, or moves focus
to Parent Object

Left arrow

Moves focus up one Object Up arrow

Moves focus down one Object Down arrow

Moves focus to first Object in Tree View Home

Moves focus to last Object in Tree View End

Moves up one view Page Up

Moves down one view Page Down

Selects all Object in Tree View Ctrl-A, Ctrl-/

Deselects all Object in Tree View Ctrl-\

Extends selection down Shift-down
arrow

Extends selection up Shift-up arrow

Extends selection to beginning of Tree
View

Shift-Home

Extends selection to end of  Tree View Shift-End

Extends selection up one view Shift-PgUp

Extends selection down one view Shift-PgDn
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Keyboard Shortcuts for Table Views

Action Keystroke Notes

Moves up one row Up arrow
Shift-Return

Moves down one row Down arrow
Return 

Scrolls up one view Page Up

Scrolls down one view Page Down

Moves focus and view to first cell in the
current row

Home

Moves focus and view to last cell in the
current row

End

Moves focus and view to first cell in the
current column

Ctrl-Home

Moves focus and view to last cell in the
current column

Ctrl-End

Allows editing in a Category cell F2, Down Arrow

Allows editing in a Name cell. F2

Resets cell to the state it was in before it
was edited

Escape

Selects entire table Ctrl-A

Extends selection up one row Shift-up arrow

Extends selection down one row Shift-down
arrow

Extends selection to beginning of table Ctrl-Shift-Home

Extends selection to end of table Ctrl-Shift-End

Extends selection up one view Shift-PgUp

Extends selection down one view Shift-PgDn
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Keyboard Editing Short Cuts for both Tree and Table Views

Action Keystroke Notes

Undo Ctrl-Z

Redo Ctrl-Y

Cut Ctrl-X

Copy Ctrl-C

Paste Ctrl-V

Find Ctrl-F

Find Next F3

Goto Ctrl-G

Insert Object INS Not allowed on
Collections

Delete Object DEL Not allowed on
Collections

Rename Object F4 Single Named Object
Only

Initialise Object F5

List References F6 Single Named Object
Only

Export to MIDI Edit Buffer F8 Single Patch Only

Export to MIDI Memory Shift-F8 Patches Only

Import from MIDI Edit Buffer F9 Single Patch Only

Import from MIDI Memory Shift-F9 Patches Only
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Keyboard Shortcuts for the Preferences Dialog

Action Keystroke Notes

Navigates through tabs Arrow keys

Moves from tab to its associated content
pane

Ctrl-down arrow

Moves from content pane to its
associated tab

Ctrl-up arrow

Keyboard Shortcuts for Text Editing Fields

Action Keystroke Notes

Moves insertion point one character to
the right

Right arrow

Moves insertion point one character to
the left

Left arrow

Moves insertion point to beginning of
next word

Ctrl-right arrow

Moves insertion point to beginning of
previous word

Ctrl-left arrow

Moves insertion point to beginning of
field

Home

Moves insertion point to end of field End

Submits text entry Enter, Return

Extends selection to beginning of line Shift-Home

Extends selection to end of line Shift-End

Extends selection one character to the
left

Shift-left arrow

Extends selection one character to the
right

Shift-right arrow

Extends selection to next word Shift-Ctrl-right
arrow

Extends selection to previous word Shift-Ctrl-left
arrow
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Credits
Jim Atfield for general debugging duties, including OSX compatibility, and for also checking out the
behaviour of the installer on MAC OSX, and then for loaning me his iMac so that I could sort out some
more pervasive issues. I now have my own Mac so I don't have to keep borrowing Jim's, or hassling
him for OSX duties anymore, but OSX support all started with Jim's help.

• 

3rd party software used in fc.factory
The following 3rd part software is used to build fc.factory and provide some program features.

CoreMIDI4J License

fc.factory makes use of CoreMIDI4J to provide MIDI support on OS X, which is issued under the EPL 1.0
License.

Table Filter License

fc.factory makes use of TableFilter by Luis M. Pena, which is issued under the MIT License.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Apache Derby License

fc.factory makes use of Apache Derby to provide the library function, which is issued under the Apache 2.0
License.

Apache Log4J License

fc.factory makes use of Apache Log4J to provide logging services, which is issued under the Apache 2.0
License.

Dom4J License

fc.factory makes use of Dom4J to provide XML services, which is issued under the Maplesoft Dom4J License.

THIS SOFTWARE IS PROVIDED BY METASTUFF, LTD. AND CONTRIBUTORS ``AS IS'' AND ANY
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL METASTUFF, LTD. OR ITS CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Java Wizard License

The fc.factory Library Batch Importer makes use of the Java Wizard Project which is distributed under
the Open Source Initiative Common Development and Distribution License.

I have adapted the Wizard software to allow me to display two progress bars in the Wizard. If anybody wishes
to have the source code for how I did this, please email me at supportx@xfactory-librarians.co.uk and I will
happily provide the adapted source code.
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fc.factory License
The unregistered version of fc.factory allows you to evaluate the features of the program, which are fully
functional except the File Save, MIDI Export and Librarian features.

However, fc.factory cannot be included as part of a commercial distribution or on other web sites without the
express permission of the Author. I am happy for you to provide links to www.xfactory-librarians.co.uk, to
maximise public access to fc.factory.

fc.factory license files are issued to users who have registered fc.factory, to gain access to the File Save, MIDI
Export and Librarian features. If you have been issued with a license key you are not allowed to distribute a
license key to other users. Please respect this, and the amount effort I have put into making this application.

You are permitted to install and activate fc.factory on two computers, for which the license is valid.

If you wish to install and activate fc.factory on more than two computers, then an additional license can be
purchased at 50% of the cost of the main license.

The Author retains the copyright on the program and all of its originally developed features.

Disclaimer
Like all software products, this software is provided "AS IS", and without any warranties expressed or implied.
But hey, remember, you're getting it for a very low cost!

I have worked hard to ensure this software works correctly, as I certainly don't want it trashing my data.
However, I cannot be held liable for any problems arising as a consequence of you using this software on
your computer and your data. You use this product at your risk.

Like all new products, please proceed and evaluate with care, and ensure that all your important data files are
backed up before installation and evaluation.

Having gotten that out of the way, if you do encounter any problems, please submit a bug report
to support@xfactory-librarians.co.uk, and I will endeavour to provide a fix for any reported problems.

Licensing Conditions for 3rd party software
Apache Derby License

fc.factory makes use of Apache Derby to provide the library function, which is issued under the Apache 2.0
License.

Apache Log4J License

fc.factory makes use of Apache Log4J to provide logging services, which is issued under the Apache 2.0
License.

CoreMIDI4J License

fc.factory makes use of CoreMIDI4J to provide MIDI support on OS X, which is issued under the EPL 1.0
License.

Dom4J License

fc.factory makes use of Dom4J to provide XML services, which is issued under the Maplesoft Dom4J License.

THIS SOFTWARE IS PROVIDED BY METASTUFF, LTD. AND CONTRIBUTORS ``AS IS'' AND ANY
EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL METASTUFF, LTD. OR ITS CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Java Wizard License

The fc.factory Library Batch Importer makes use of the Java Wizard Project which is distributed under
the Open Source Initiative Common Development and Distribution License.
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Table Filter License

fc.factory makes use of TableFilter by Luis M. Pena, which is issued under the MIT License.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Tritonus License

fc.factory makes use of Tritonus Java Sound Extensions, which is issued under the GNU Lesser General
Public License.
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